Strict Standards: Redefining already defined constructor for class bbdb in /home/themes/public_html/forums/bb-includes/db-mysql.php on line 12

Strict Standards: Declaration of BB_Walker_Blank::start_lvl() should be compatible with BB_Walker::start_lvl($output) in /home/themes/public_html/forums/bb-includes/classes.php on line 1127

Strict Standards: Declaration of BB_Walker_Blank::end_lvl() should be compatible with BB_Walker::end_lvl($output) in /home/themes/public_html/forums/bb-includes/classes.php on line 1127

Strict Standards: Declaration of BB_Walker_Blank::start_el() should be compatible with BB_Walker::start_el($output) in /home/themes/public_html/forums/bb-includes/classes.php on line 1127

Strict Standards: Declaration of BB_Walker_Blank::end_el() should be compatible with BB_Walker::end_el($output) in /home/themes/public_html/forums/bb-includes/classes.php on line 1127

Warning: Cannot modify header information - headers already sent by (output started at /home/themes/public_html/forums/bb-includes/db-mysql.php:12) in /home/themes/public_html/forums/my-templates/kakumei-variant/rss2.php on line 1
ThemeShaper Forums Tag: image http://forums.themeshaper.com/ Help In Shaping WordPress Themes en Fri, 22 May 2015 13:02:56 +0000 helgatheviking on "Link to image file rather than attachment" http://forums.themeshaper.com/topic/link-to-image-file-rather-than-attachment#post-26989 Mon, 14 May 2012 17:57:14 +0000 helgatheviking 26989@http://forums.themeshaper.com/ <p>while this is NOT in any way, shape or form a thematic question... when you insert an image you simply tell the image to link to the File URL instead. see the screenshot.</p> <p><a href="http://www.diigo.com/item/image/1xt6v/uvt9" rel="nofollow">http://www.diigo.com/item/image/1xt6v/uvt9</a></p> <p>though, +1 to scott... that is a neat tip. </p> ScottNix on "Link to image file rather than attachment" http://forums.themeshaper.com/topic/link-to-image-file-rather-than-attachment#post-26988 Mon, 14 May 2012 16:25:31 +0000 ScottNix 26988@http://forums.themeshaper.com/ <p>This? <a href="http://blog.aizatto.com/2010/05/04/changing-default-wordpress-media-link-url/" rel="nofollow">http://blog.aizatto.com/2010/05/04/changing-default-wordpress-media-link-url/</a> </p> claudioccm on "Link to image file rather than attachment" http://forums.themeshaper.com/topic/link-to-image-file-rather-than-attachment#post-26987 Mon, 14 May 2012 14:38:21 +0000 claudioccm 26987@http://forums.themeshaper.com/ <p>I am looking for this same information. Can anyone help? </p> markvd3 on "display the next/previous post links as clickable image links instead of text" http://forums.themeshaper.com/topic/display-the-nextprevious-post-links-as-clickable-image-links-instead-of-text#post-24379 Mon, 19 Dec 2011 17:15:03 +0000 markvd3 24379@http://forums.themeshaper.com/ <p>i am using the power blog theme. i would love to be able to do this without editing the parent theme. so i need a function, but have to idea how to acheive this. any help would be great. thanks is advance! </p> Eve on "Can't change image link, keeps reverting." http://forums.themeshaper.com/topic/cant-change-image-link-keeps-reverting#post-24324 Thu, 15 Dec 2011 22:06:21 +0000 Eve 24324@http://forums.themeshaper.com/ <p>Same issue here. Theme is Newsprint, using default editor. I am admin.<br /> If I come up with an answer, I'll post it. </p> helgatheviking on "Movng Featured Image to the Left" http://forums.themeshaper.com/topic/movng-featured-image-to-the-left#post-24220 Fri, 09 Dec 2011 20:55:46 +0000 helgatheviking 24220@http://forums.themeshaper.com/ <p>use getfirebug.com to resolve 95% of all CSS-related questions </p> andycheeseman on "Movng Featured Image to the Left" http://forums.themeshaper.com/topic/movng-featured-image-to-the-left#post-24215 Fri, 09 Dec 2011 14:02:32 +0000 andycheeseman 24215@http://forums.themeshaper.com/ <p>Hi,</p> <p>What is the correct procedure to align the featured image to the left of a post's excerpt? As opposed to its default position on the right?</p> <p>Thanks,<br /> Andy. </p> scott_see on "Can't change image link, keeps reverting." http://forums.themeshaper.com/topic/cant-change-image-link-keeps-reverting#post-24180 Wed, 07 Dec 2011 06:52:15 +0000 scott_see 24180@http://forums.themeshaper.com/ <p><code>[caption id=&quot;attachment_265&quot; align=&quot;alignnone&quot; width=&quot;300&quot; caption=&quot;Take a Video Tour of Many of Our Houses&quot;]&lt;a title=&quot;Video Tours&quot; href=&quot;http://www.jlscolumbiagorge.com/sample-page/youtubescreenshot-614px/&quot; rel=&quot;attachment wp-att-265&quot;&gt;&lt;img class=&quot;size-medium wp-image-265 &quot; title=&quot;Take a Video Tour of Many of Our Houses&quot; src=&quot;http://www.jlscolumbiagorge.com/wp-content/uploads/YouTubeScreenshot-614px-300x182.jpg&quot; alt=&quot;Take a Video Tour of Many of Our Houses&quot; width=&quot;300&quot; height=&quot;182&quot; /&gt;&lt;/a&gt;[/caption]</code></p> <p>I'm using Thematic theme with TinyMCE editor. I want to link this image to a page, but every time I change the link URL, it reverts back to what you see above. I try clicking on the image and editing the Link URL. I try clicking on the link icon in the editor. Nothing sticks. Something is forcing the Link URL to revert back to the default.</p> <p>How do I override this? It shouldn't be this difficult to link an image to what you want to. Even if I edit it in HTML view, the &lt;a href code reverts back. I'm really stuck here.</p> <p>The site is <a href="http://www.jlscolumbiagorge.com/" rel="nofollow">http://www.jlscolumbiagorge.com/</a><br /> I'm trying to link to <a href="http://www.jlscolumbiagorge.com/video-tours/" rel="nofollow">http://www.jlscolumbiagorge.com/video-tours/</a> </p> carrisi on "no image in posts" http://forums.themeshaper.com/topic/no-image-in-posts#post-24068 Fri, 02 Dec 2011 14:28:32 +0000 carrisi 24068@http://forums.themeshaper.com/ <p>brilliat thanks for your help </p> helgatheviking on "no image in posts" http://forums.themeshaper.com/topic/no-image-in-posts#post-24067 Fri, 02 Dec 2011 14:06:17 +0000 helgatheviking 24067@http://forums.themeshaper.com/ <p>if you are using a program like notepad++ (which you should, i recommend it as a kick ass text editor) then you can just search content-extensions.php for 'thematic_post'. you'll find the filter is in the thematic_content() function. i originally thought that the filter name was the same as the function, but this isn't the case. the filter name is what is seen in the apply_filters(). here's the source:</p> <pre><code>function thematic_content() { global $thematic_content_length; if ( strtolower($thematic_content_length) == &#39;full&#39; ) { $post = get_the_content(more_text()); $post = apply_filters(&#39;the_content&#39;, $post); $post = str_replace(&#39;]]&gt;&#39;, &#39;]]&gt;&#39;, $post); } elseif ( strtolower($thematic_content_length) == &#39;excerpt&#39;) { $post = &#39;&#39;; $post .= get_the_excerpt(); $post = apply_filters(&#39;the_excerpt&#39;,$post); if ( apply_filters( &#39;thematic_post_thumbs&#39;, TRUE) ) { $post_title = get_the_title(); $size = apply_filters( &#39;thematic_post_thumb_size&#39; , array(100,100) ); $attr = apply_filters( &#39;thematic_post_thumb_attr&#39;, array(&#39;title&#39; =&gt; &#39;Permalink to &#39; . $post_title) ); if ( has_post_thumbnail() ) { $post = &#39;&lt;a class=&quot;entry-thumb&quot; href=&quot;&#39; . get_permalink() . &#39;&quot; title=&quot;Permalink to &#39; . get_the_title() . &#39;&quot; &gt;&#39; . get_the_post_thumbnail(get_the_ID(), $size, $attr) . &#39;&lt;/a&gt;&#39; . $post; } } } elseif ( strtolower($thematic_content_length) == &#39;none&#39;) { } else { $post = get_the_content(more_text()); $post = apply_filters(&#39;the_content&#39;, $post); $post = str_replace(&#39;]]&gt;&#39;, &#39;]]&gt;&#39;, $post); } echo apply_filters(&#39;thematic_post&#39;, $post); //here&#39;s your filter right here }</code></pre> carrisi on "no image in posts" http://forums.themeshaper.com/topic/no-image-in-posts#post-24063 Fri, 02 Dec 2011 12:52:51 +0000 carrisi 24063@http://forums.themeshaper.com/ <p>thanks helgatheviking, your answers have really helped. </p> <p>can you give me some insight on how to filter the thematic post, i know its in content extentions but cant find the relevant filter </p> helgatheviking on "no image in posts" http://forums.themeshaper.com/topic/no-image-in-posts#post-24046 Fri, 02 Dec 2011 00:05:22 +0000 helgatheviking 24046@http://forums.themeshaper.com/ <p>full post versus excerpt are 2 totally different things. by default, thematic only shows the featured image in the excerpt mode. it doesn't automatically show up on the single post. of course you can add it in by filtering thematic_post. </p> ScottNix on "no image in posts" http://forums.themeshaper.com/topic/no-image-in-posts#post-24044 Thu, 01 Dec 2011 23:24:27 +0000 ScottNix 24044@http://forums.themeshaper.com/ <p>Try <a href="http://forums.themeshaper.com/topic/featured-image-not-displaying-on-blog-page" rel="nofollow">http://forums.themeshaper.com/topic/featured-image-not-displaying-on-blog-page</a> </p> carrisi on "no image in posts" http://forums.themeshaper.com/topic/no-image-in-posts#post-24043 Thu, 01 Dec 2011 23:14:40 +0000 carrisi 24043@http://forums.themeshaper.com/ <p>Hello, my site is nearly complete and looking great, cant wait to show you. Forums have been so much help.</p> <p>Anyway, i changed the homepage from full to excerpt, when i have then view the full post there is no featured image??? just the text content. </p> <p>I was hoping that the thumbnail from the excerpt would become larger on the post. </p> earrame on "Help with adding extra image to header" http://forums.themeshaper.com/topic/help-with-adding-extra-image-to-header#post-23962 Mon, 28 Nov 2011 06:42:29 +0000 earrame 23962@http://forums.themeshaper.com/ <p>Thanks, that's what I figured out. &lt;with a palm to forehead&gt; </p> helgatheviking on "Help with adding extra image to header" http://forums.themeshaper.com/topic/help-with-adding-extra-image-to-header#post-23909 Wed, 23 Nov 2011 16:02:01 +0000 helgatheviking 23909@http://forums.themeshaper.com/ <p>you don't need to copy everything from header-extensions.php over to your functions.php. you only need the copy the overrides that you actually wish to use. </p> <p>though it looks like you only needed:</p> <pre><code>function add_stuff() {?&gt; &lt;img src=&quot;&lt;?php bloginfo(&#39;stylesheet_directory&#39;);?&gt;/imgs/order-sticker.png&quot; alt=&quot;Order your jumpy bed now!&quot; id=&quot;order-sticker&quot; title=&quot;order-sticker&quot; width=&quot;146&quot; height=&quot;147&quot; /&gt; &lt;?php } add_action(&#39;thematic_header&#39;,&#39;add_stuff&#39;,2);</code></pre> earrame on "Help with adding extra image to header" http://forums.themeshaper.com/topic/help-with-adding-extra-image-to-header#post-23902 Wed, 23 Nov 2011 02:12:12 +0000 earrame 23902@http://forums.themeshaper.com/ <p>nevermind. I figured it out. </p> earrame on "Help with adding extra image to header" http://forums.themeshaper.com/topic/help-with-adding-extra-image-to-header#post-23898 Tue, 22 Nov 2011 18:28:14 +0000 earrame 23898@http://forums.themeshaper.com/ <p>Hello, I know that this has been dealt with a few times already, but I am having trouble making it work.</p> <p>What I am trying to do is to add a "buy now" sticker to the header. I have read that I add a function in thematic header. I copied header-extensions.php to my child theme and added this function:</p> <p><code><br /> // Functions that hook into thematic_header()</p> <p> // Open #branding<br /> // In the header div<br /> if (function_exists('childtheme_override_brandingopen')) {<br /> function thematic_brandingopen() {<br /> childtheme_override_brandingopen();<br /> }<br /> } else {<br /> function thematic_brandingopen() {<br /> echo "&lt;div id=\"branding\"&gt;\n";<br /> }<br /> add_action('thematic_header','thematic_brandingopen',1);<br /> } </p> <p> // Create the blog title<br /> // In the header div<br /> if (function_exists('childtheme_override_blogtitle')) {<br /> function thematic_blogtitle() {<br /> childtheme_override_blogtitle();<br /> }<br /> } else {<br /> function thematic_blogtitle() { ?&gt;</p> <p> &lt;div id="blog-title"&gt;&lt;span&gt;<a>/" title="&lt;?php bloginfo('name') ?&gt;" rel="home"&gt;&lt;?php bloginfo('name') ?&gt;</a>&lt;/span&gt;&lt;/div&gt;</p> <p> &lt;?php }<br /> add_action('thematic_header','thematic_blogtitle',3);<br /> }<br /> function add_stuff() {?&gt;<br /> <a href="http://trampoline-bed.com/order-jumpy-bed/">&lt;img src="http://trampoline-bed.com/wp-content/themes/jumpybed-theme/imgs/order-sticker.png" alt="Order your jumpy bed now!" id="order-sticker" title="order-sticker" width="146" height="147" /&gt;</a><br /> &lt;?php }</p> <p>add_action('thematic_header','add_stuff',2);<br /> // Create the blog description<br /> // In the header div</code><br /> The function I added is add_stuff.<br /> I then styled it with this:<br /> <code><br /> #order-sticker{<br /> position: absolute;<br /> top: 0px;<br /> left: 30px;<br /> z-index: 200;<br /> }<br /> </code><br /> nothing is showing up at all. Could someone show me the error I am making? The site is <a href="http://trampoline-bed.com" rel="nofollow">http://trampoline-bed.com</a> </p> abhi on "Adding both Text and Image to header" http://forums.themeshaper.com/topic/adding-both-text-and-image-to-header#post-23877 Mon, 21 Nov 2011 07:08:49 +0000 abhi 23877@http://forums.themeshaper.com/ <p>Thanks it worked. </p> sowingseeds on "Adding both Text and Image to header" http://forums.themeshaper.com/topic/adding-both-text-and-image-to-header#post-23846 Thu, 17 Nov 2011 18:05:34 +0000 sowingseeds 23846@http://forums.themeshaper.com/ <p>I presume you have a child-theme and have something like text-indent:-9999px or something similar under the blog-title division in your css? If so the easiest way is simply to do as optriro has suggested. This will bring your site title back in to the header, with the header image as a background. You can then position the text with css.</p> <p>If there is something else you are trying to do that requires something extra, either give a link or give some more detail. </p> abhi on "Adding both Text and Image to header" http://forums.themeshaper.com/topic/adding-both-text-and-image-to-header#post-23839 Thu, 17 Nov 2011 10:02:13 +0000 abhi 23839@http://forums.themeshaper.com/ <p>Is it possible to do it with hooks? </p> optriro on "Adding both Text and Image to header" http://forums.themeshaper.com/topic/adding-both-text-and-image-to-header#post-23837 Thu, 17 Nov 2011 05:53:29 +0000 optriro 23837@http://forums.themeshaper.com/ <p><code><br /> #blog-title a {<br /> background: url(img/header.png) no-repeat top center;<br /> display:block;<br /> width: 960px;<br /> height:192px;<br /> z-index: 150;<br /> }<br /> </code></p> <p>This works for me, just add styling. </p> abhi on "Adding both Text and Image to header" http://forums.themeshaper.com/topic/adding-both-text-and-image-to-header#post-23836 Thu, 17 Nov 2011 05:42:31 +0000 abhi 23836@http://forums.themeshaper.com/ <p>Hello all,</p> <p>I am using thematic for the last 6 months. I want to to add both text and image to the header. Right now I just have image enabled.</p> <p>SO please anybody tell me how to do this?</p> <p>Thanks </p> simonafilote on "add image as read more link" http://forums.themeshaper.com/topic/add-image-as-read-more-link#post-23765 Thu, 10 Nov 2011 13:30:39 +0000 simonafilote 23765@http://forums.themeshaper.com/ <p>Maybe it's worth mentioning that even before I added the code above, my blog wouldn't automatically add a read more link to posts, thus I had to add it manually in each post. </p> simonafilote on "add image as read more link" http://forums.themeshaper.com/topic/add-image-as-read-more-link#post-23764 Thu, 10 Nov 2011 11:57:53 +0000 simonafilote 23764@http://forums.themeshaper.com/ <p>I was expecting to see the [...] characters showing automatically on my blog posts on the homepage after inserting the code of the first example, but I'm guessing I misplaced the code.</p> <p>This is my functions.php content:</p> <pre><code>&lt;?php function childtheme_override_postmeta_entrydate() { $entrydate = &#39;&lt;span class=&quot;meta-prep meta-prep-entry-date&quot;&gt;&#39; . __(&#39;&#39;, &#39;thematic&#39;) . &#39;&lt;/span&gt;&#39;; $entrydate .= &#39;&lt;span class=&quot;entry-date&quot;&gt;&lt;abbr class=&quot;published&quot; title=&quot;&#39; . get_the_time(thematic_time_title()) . &#39;&quot;&gt;&#39;; $entrydate .= &#39;&lt;span class=&quot;month&quot;&gt;&#39; . get_the_time(&#39;M &#39;) . &#39;&lt;/span&gt;&#39;; $entrydate .= &#39;&lt;span class=&quot;day&quot;&gt;&#39; . get_the_time(&#39;d&#39;) . &#39;&lt;span class=&quot;sep&quot;&gt;, &lt;/span&gt;&lt;/span&gt;&#39;; $entrydate .= &#39;&lt;span class=&quot;year&quot;&gt;&#39; . get_the_time(&#39;Y&#39;) . &#39;&lt;/span&gt;&#39;; $entrydate .= &#39;&lt;/abbr&gt;&lt;/span&gt;&#39;; return apply_filters(&#39;thematic_post_meta_entrydate&#39;, $entrydate); } function new_excerpt_more($more) { return &#39;[.....]&#39;; } add_filter(&#39;excerpt_more&#39;, &#39;new_excerpt_more&#39;); ?&gt;</code></pre> helgatheviking on "add image as read more link" http://forums.themeshaper.com/topic/add-image-as-read-more-link#post-23762 Thu, 10 Nov 2011 00:17:34 +0000 helgatheviking 23762@http://forums.themeshaper.com/ <p>you don't need the new_excerpt_more() function twice, that's 2 different examples for the same thing. and didn't work out how? what happened instead? if you want an image then you need to return some kind of image code instead of [....] or the a link in the other example.. </p> simonafilote on "add image as read more link" http://forums.themeshaper.com/topic/add-image-as-read-more-link#post-23760 Wed, 09 Nov 2011 21:07:02 +0000 simonafilote 23760@http://forums.themeshaper.com/ <p>Thanks, I read it, but still confused...does that mean that I need to add the following in my functions.php?</p> <pre><code>function new_excerpt_more($more) { return &#39;[.....]&#39;; } add_filter(&#39;excerpt_more&#39;, &#39;new_excerpt_more&#39;); function new_excerpt_more($more) { global $post; return &#39;&lt;a href=&quot;&#39;. get_permalink($post-&gt;ID) . &#39;&quot;&gt;Read the Rest...&lt;/a&gt;&#39;; } add_filter(&#39;excerpt_more&#39;, &#39;new_excerpt_more&#39;);</code></pre> <p>That didn't work out... </p> markvd3 on "How to add facebook like button for a website next to the header?" http://forums.themeshaper.com/topic/how-to-add-facebook-like-button-for-a-website-next-to-the-header#post-23759 Wed, 09 Nov 2011 20:49:49 +0000 markvd3 23759@http://forums.themeshaper.com/ <p>it doesnt seem to be working out for me. my header image is in the branding div. i tried</p> <p>function additional_header_content() {<br /> ?&gt;</p> <p>&lt;div class="fb-like" data-href="http://www.mysite.com" data-send="false" data-width="450" data-show-faces="false"&gt;&lt;/div&gt;</p> <p>&lt;?php<br /> }</p> <p>add_action('thematic_brandingopen', 'additional_header_content', 1);</p> <p>and i put the facebook javascript sdk script in the parent themes header. and it didnt work. im just trying to learn since i am a beginner to php and everything :) thanks </p> helgatheviking on "add image as read more link" http://forums.themeshaper.com/topic/add-image-as-read-more-link#post-23758 Wed, 09 Nov 2011 19:53:34 +0000 helgatheviking 23758@http://forums.themeshaper.com/ <p>how to filter the "read more" text:<br /> <a href="http://codex.wordpress.org/Function_Reference/the_excerpt#Only_in_version_2.9_and_higher_of_WordPress" rel="nofollow">http://codex.wordpress.org/Function_Reference/the_excerpt#Only_in_version_2.9_and_higher_of_WordPress</a> </p> simonafilote on "add image as read more link" http://forums.themeshaper.com/topic/add-image-as-read-more-link#post-23757 Wed, 09 Nov 2011 19:45:44 +0000 simonafilote 23757@http://forums.themeshaper.com/ <pre><code>&lt;?php the_excerpt (); ?&gt; &lt;a href=&quot;&lt;?php the_permalink(); ?&gt;&quot; class=&quot;more-button&quot;&gt;&amp;nbsp;&lt;/a&gt;&lt;/a&gt;</code></pre> <p>I figured I need to put the code between backticks... </p>