Strict Standards: Redefining already defined constructor for class bbdb in /home/themes/public_html/forums/bb-includes/db-mysql.php on line 12

Strict Standards: Declaration of BB_Walker_Blank::start_lvl() should be compatible with BB_Walker::start_lvl($output) in /home/themes/public_html/forums/bb-includes/classes.php on line 1127

Strict Standards: Declaration of BB_Walker_Blank::end_lvl() should be compatible with BB_Walker::end_lvl($output) in /home/themes/public_html/forums/bb-includes/classes.php on line 1127

Strict Standards: Declaration of BB_Walker_Blank::start_el() should be compatible with BB_Walker::start_el($output) in /home/themes/public_html/forums/bb-includes/classes.php on line 1127

Strict Standards: Declaration of BB_Walker_Blank::end_el() should be compatible with BB_Walker::end_el($output) in /home/themes/public_html/forums/bb-includes/classes.php on line 1127

Warning: Cannot modify header information - headers already sent by (output started at /home/themes/public_html/forums/bb-includes/db-mysql.php:12) in /home/themes/public_html/forums/my-templates/kakumei-variant/rss2.php on line 1
ThemeShaper Forums Topic: Adding more Javascripts http://forums.themeshaper.com/ Help In Shaping WordPress Themes en Fri, 22 May 2015 14:30:45 +0000 emilie on "Adding more Javascripts" http://forums.themeshaper.com/topic/adding-more-javascripts#post-24503 Wed, 28 Dec 2011 18:25:26 +0000 emilie 24503@http://forums.themeshaper.com/ <p>hello,</p> <p>i have a problem that i already solved but it seems that suddenly it appears again.<br /> I have an error that said '$ is not a function', whereas i m in jquery no conlict mode, i have updated the plugins which needed to but it still eosn't work, the coda-slider i m using to show the thumbnails in one line is not working, and i don't have anymore ideas to fix it.</p> <p>Your help will be very nice.<br /> Here a link to the website : <a href="http://www.fellah-hotel.com" rel="nofollow">http://www.fellah-hotel.com</a><br /> Thank you,</p> <p>emilie </p> Chris on "Adding more Javascripts" http://forums.themeshaper.com/topic/adding-more-javascripts#post-3353 Sun, 19 Apr 2009 10:26:12 +0000 Chris 3353@http://forums.themeshaper.com/ <p>Good to hear, that this is working ..</p> <p>I decided not to use this tutorial to write an own one .. there're to many bugs, errors and so on to fix. </p> mmeisner on "Adding more Javascripts" http://forums.themeshaper.com/topic/adding-more-javascripts#post-3348 Sat, 18 Apr 2009 23:08:06 +0000 mmeisner 3348@http://forums.themeshaper.com/ <p>Well, I built a child theme, and deactivated the included .js in the scripts folder. Then I simply called the scripts I wanted in the head; also ended up changing all the "$" in the coda-slider-condensed.js file to "jQuery" which seemed to get rid of that stupid error. </p> <p>And the final oversight ended up being careless one. I did not update some of the custom fields that were tied into the navigation, so now it actually has items to scroll to. I think before it only had one scroll item in the nav, and thus, nowhere else to scroll.</p> <p>Phew. I'll hope to have a cool child theme to spread around shortly. </p> mmeisner on "Adding more Javascripts" http://forums.themeshaper.com/topic/adding-more-javascripts#post-3345 Sat, 18 Apr 2009 19:08:11 +0000 mmeisner 3345@http://forums.themeshaper.com/ <p>Thanks Chris ;)</p> <p>Dannydamnboy - I actually tried running the noConflict function and changing the $ to jQuery but nothing. Plus, I don't have any prototype or moo stuff in there. Just the good ol' scripts that come packaged, and the ones above that I added.</p> <p>For now, I'm off to start it in a child theme. I'll return once I find an answer as to why the .js was not working. </p> dannydamnboy on "Adding more Javascripts" http://forums.themeshaper.com/topic/adding-more-javascripts#post-3338 Sat, 18 Apr 2009 17:01:33 +0000 dannydamnboy 3338@http://forums.themeshaper.com/ <p>Hey Mike, you have problems with jQuery! Firebug returns an error like "$ is not a function"... maybe you have to change the content of the file to make it running in NoConflict mode... </p> Chris on "Adding more Javascripts" http://forums.themeshaper.com/topic/adding-more-javascripts#post-3331 Sat, 18 Apr 2009 14:56:52 +0000 Chris 3331@http://forums.themeshaper.com/ <p>Ok .. need some time to run through the whole thing and create a proper how-to for this. </p> Chris on "Adding more Javascripts" http://forums.themeshaper.com/topic/adding-more-javascripts#post-3326 Sat, 18 Apr 2009 14:11:51 +0000 Chris 3326@http://forums.themeshaper.com/ <p>As you said, you know my answer! :-) </p> mmeisner on "Adding more Javascripts" http://forums.themeshaper.com/topic/adding-more-javascripts#post-3325 Sat, 18 Apr 2009 14:03:53 +0000 mmeisner 3325@http://forums.themeshaper.com/ <p>Chris,</p> <p>I uploaded the local test version Live. If you want you can view it here:<br /> <a href="http://mikemeisner.com/sandbox/" rel="nofollow">http://mikemeisner.com/sandbox/</a></p> <p>I did what you said, and all the .js loads in a new window. Also, I don't get a conflict with the "$" anymore. What I'm trying to do is build the featured slider a la <a href="http://www.gomediazine.com/tutorials/design-elegant-featured-content-slider-wordpress/" rel="nofollow">http://www.gomediazine.com/tutorials/design-elegant-featured-content-slider-wordpress/</a> which, as you can see, is not working quite yet. I am not sure why; the .js does load, so that's not an issue anymore.</p> <p>If you have a moment would you mind taking a look and letting me know your thoughts? I'm itching to finish the design but I always get hung up on things like this.</p> <p>One more question. Do you think it's prudent to move the CSS and Images to a Child Theme? I susptect I know the answer.</p> <p>Thanks </p> Chris on "Adding more Javascripts" http://forums.themeshaper.com/topic/adding-more-javascripts#post-3323 Sat, 18 Apr 2009 13:28:33 +0000 Chris 3323@http://forums.themeshaper.com/ <p>That error has nothing to do with from where you load your scripts .. a couple of things for you to check:</p> <p>Open your browser<br /> open you local blog<br /> open your browser's source view<br /> search for each single script / library<br /> copy the script / library address into a new browser window and see if it loads</p> <p>If you get a 404 the address for this script / library either the address is wrong or you're missing a file. Fix it and see what happens.</p> <p>If every script / library loads .. the error could be caused by using different libraries / frameworks. For example using jQuery and MooTools won't work without further magic :-)</p> <p>Cheers,</p> <p>Chris </p> mmeisner on "Adding more Javascripts" http://forums.themeshaper.com/topic/adding-more-javascripts#post-3321 Sat, 18 Apr 2009 13:12:30 +0000 mmeisner 3321@http://forums.themeshaper.com/ <p>Hi Chris,</p> <p>I can't link it because it's being locally developed. </p> <p>However, I'm pretty sure the problem has to do with the jQuery; Firebug tells me there's an error and reports that "$ is not a function" so I'm inclined to think it's a conflict with another script. That's still strange though, as I haven't loaded Prototype or anything else. It comes bundled with jQuery...</p> <p>The basic question I had was, instead of insterting scripts into the header, like I normally do, should I be referencing them from another file within Thematic. </p> Chris on "Adding more Javascripts" http://forums.themeshaper.com/topic/adding-more-javascripts#post-3315 Sat, 18 Apr 2009 08:04:11 +0000 Chris 3315@http://forums.themeshaper.com/ <p>Could you please drop a link to your blog?!</p> <p>Cheers,</p> <p>Chris </p> mmeisner on "Adding more Javascripts" http://forums.themeshaper.com/topic/adding-more-javascripts#post-3312 Sat, 18 Apr 2009 02:46:53 +0000 mmeisner 3312@http://forums.themeshaper.com/ <p>Thanks for your great support on this forum Chris. </p> <p>I understand what you're saying, and how it works/doesn't work in a child theme context. I'm simply editing the main files. Though I probably should create a child theme...</p> <p>In any case, I can see the scripts are called in the source so I'm not sure what the problem is but thanks for your help and I'll report back with any news. </p> mmeisner on "Adding more Javascripts" http://forums.themeshaper.com/topic/adding-more-javascripts#post-3311 Sat, 18 Apr 2009 02:46:51 +0000 mmeisner 3311@http://forums.themeshaper.com/ <p>Thanks for your great support on this forum Chris. </p> <p>I understand what you're saying, and how it works/doesn't work in a child theme context. I'm simply editing the main files. Though I probably should create a child theme...</p> <p>In any case, I can see the scripts are called in the source so I'm not sure what the problem is but thanks for your help and I'll report back with any news. </p> Chris on "Adding more Javascripts" http://forums.themeshaper.com/topic/adding-more-javascripts#post-3300 Fri, 17 Apr 2009 19:37:03 +0000 Chris 3300@http://forums.themeshaper.com/ <p>Hey,</p> <p>don't know if I got it right.</p> <p>I reproduced your first example using the following code in my child theme's functions.php:<br /> <pre><code>function childtheme_scripts() {?&gt; &lt;?php echo &quot;\n\t&quot; ?&gt;&lt;script type=&quot;text/javascript&quot; charset=&quot;utf-8&quot; src=&quot;&lt;?php bloginfo(&#39;template_directory&#39;); ?&gt;/js/coda-slider.js&quot;&gt;&lt;/script&gt;&lt;?php echo &quot;\n&quot; ?&gt; &lt;?php } add_action(&#39;wp_head&#39;, &#39;childtheme_scripts&#39;);</code></pre> <p>This code snippet will insert the script line but it won't work with a child theme 'cause 'template_directory' will create <code><a href="http://www.yourdomain.com/wp-content/themes/thematic/" rel="nofollow">http://www.yourdomain.com/wp-content/themes/thematic/</a></code> instead of <code><a href="http://www.yourdomain.com/wp-content/themes/yourchildtheme/" rel="nofollow">http://www.yourdomain.com/wp-content/themes/yourchildtheme/</a></code>. To get the right URL at any time you need to use <code>bloginfo(&#39;stylesheet_directory&#39;)</code>.</p> <p>Anyway without any further details I don't know if this was your problem or not.</p> <p>Cheers,</p> <p>Chris </p> mmeisner on "Adding more Javascripts" http://forums.themeshaper.com/topic/adding-more-javascripts#post-3296 Fri, 17 Apr 2009 16:00:06 +0000 mmeisner 3296@http://forums.themeshaper.com/ <p>Hi,</p> <p>I've been using Thematic for a while now and love it. However, with the recent release I am having trouble loading .js files. </p> <p>In the past I'd simply insert them into the wp_head() and they worked flawlessly. Not so anymore. I thought I'd open up "scripts.php" in the Extensions folder and try adding them there. Followed the same syntax, but no luck. Is scripts.php meant to only control the supplied scripts? I imagine we should be able to put the calls there...<br /> I've tried:</p> <p>&lt;script src="&lt;?php bloginfo('template_directory'); ?&gt;/js/coda-slider.js" type="text/javascript" charset="utf-8"&gt;&lt;/script&gt;</p> <p>&lt;?php wp_enqueue_script('submenu', get_bloginfo('template_url') . '/js/submenu.js' ?&gt;</p> <p>..and adding just the script name in Scripts.php like so:<br /> $scripts .= $scriptdir_start . 'coda-slider.js' . $scriptdir_end . "\n";</p> <p>I'm at a loss and really need this to work. I'm sure I'm missing something easy... </p>