Strict Standards: Redefining already defined constructor for class bbdb in /home/themes/public_html/forums/bb-includes/db-mysql.php on line 12

Strict Standards: Declaration of BB_Walker_Blank::start_lvl() should be compatible with BB_Walker::start_lvl($output) in /home/themes/public_html/forums/bb-includes/classes.php on line 1127

Strict Standards: Declaration of BB_Walker_Blank::end_lvl() should be compatible with BB_Walker::end_lvl($output) in /home/themes/public_html/forums/bb-includes/classes.php on line 1127

Strict Standards: Declaration of BB_Walker_Blank::start_el() should be compatible with BB_Walker::start_el($output) in /home/themes/public_html/forums/bb-includes/classes.php on line 1127

Strict Standards: Declaration of BB_Walker_Blank::end_el() should be compatible with BB_Walker::end_el($output) in /home/themes/public_html/forums/bb-includes/classes.php on line 1127

Warning: Cannot modify header information - headers already sent by (output started at /home/themes/public_html/forums/bb-includes/db-mysql.php:12) in /home/themes/public_html/forums/my-templates/kakumei-variant/rss2.php on line 1
ThemeShaper Forums Topic: posts_where problem http://forums.themeshaper.com/ Help In Shaping WordPress Themes en Sat, 23 May 2015 10:16:20 +0000 em hr on "posts_where problem" http://forums.themeshaper.com/topic/posts_where-problem#post-27731 Sat, 15 Dec 2012 17:56:47 +0000 em hr 27731@http://forums.themeshaper.com/ <p>Please <a href="http://forums.themeshaper.com/topic/please-read-this-before-adding-new-topics-thematic-has-moved"> read this</a> and come to then new <a href="http://thematictheme.com/forums/">ThematicTheme Forums</a> for support. </p> iCristiano on "posts_where problem" http://forums.themeshaper.com/topic/posts_where-problem#post-27668 Tue, 06 Nov 2012 22:23:41 +0000 iCristiano 27668@http://forums.themeshaper.com/ <p>Hi Thematic friends,</p> <p>I have a taxonomy called "genero". I´m trying to limit my "genero" archive page to just show future posts, like an event page.</p> <p>So, I used this code:</p> <pre><code>function filter_where( $where ) { if(is_tax(&#39;genero&#39;)){ $where .= &quot; AND post_date &gt; &#39;&quot; . date(&#39;Y-m-d&#39;, strtotime(&#39;0 days&#39;)) . &quot;&#39;&quot;; } return $where; } add_filter( &#39;posts_where&#39;, &#39;filter_where&#39; ); function reset_filter_where() { if(is_tax(&#39;genero&#39;)){ remove_filter( &#39;posts_where&#39;, &#39;filter_where&#39; ); } } add_action(&#39;thematic_below_archiveloop&#39;,&#39;reset_filter_where&#39;);</code></pre> <p>It works great on the genero´s archive page, but it breaks all the other looping on other pages. I don´t know what is happening. When I say it breaks I mean I get a blank page in another archive page, for exemple! On home, where I have another 2 loops, it shows the page, the header, but the loops are empty.</p> <p>Any help?<br /> Thanks! </p>