ThemeShaper Forums » Thematic

[closed]

2 Basic Things I Can't Figure Out

(3 posts)
  • Started 7 years ago by soupking
  • Latest reply from helgatheviking
  • This topic is not resolved
  1. soupking
    Member

    Hello,

    I'm having trouble with a couple basic things:

    1) I tried to insert a "read more..." link:

    function childtheme_more_text($content) {
        $content = 'Click to read the rest!';
        return $content;
    }
    add_filter('more_text', 'childtheme_more_text');

    per catswhocode.com but it doesn't work when I plunk it into the functions.php page.

    and 2) How do I disengage the title in the actual page? I want the title at the top of my browser so I inserted it into the admin panel, however, then it pops up on the page as well. Not sure how to locate it and hide it out.

    Does anybody know why these two things might be solved?

    Posted 7 years ago #
  2. kwight
    Member

    1) The format of your function looks correct... What results are you getting?
    2) Do you mean the site title showing up in #branding? This can be removed with the 'init' hook:

    function remove_thematic_blogtitle() {
        remove_action('thematic_header','thematic_blogtitle',3);
    }
    
    add_action('init','remove_thematic_blogtitle');
    Posted 7 years ago #
  3. i believe #1 only filters the [...] or ... that you normally get when an excerpt is created by truncating the full post. SO, if you have a custom excerpt those characters never appear and thus you wouldn't see anything change. just thinking aloud b/c i agree the code looks right and Jean-Baptiste usually provides really high quality stuff.

    #2. i don't understand what you are trying to do.

    Posted 7 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.