ThemeShaper Forums » Thematic

[closed]

add_editor_style() not working with Thematic?

(5 posts)
  • Started 8 years ago by saschapi
  • Latest reply from saschapi
  • This topic is not resolved
  1. saschapi
    Member

    Hi,

    I tried pretty much everything to include custom-style.css to the MCE-Editor. But the stylesheet is never even linked in the editor iframe. Is it possible I have to use a thematic hook or filter? I actualle added this to the functions.php in the child theme and it does nothing.

    add_editor_style();

    All the other stuff is working, even this here:


    //Add formatting options visible in the format dropdown
    function childtheme_tiny_mce_before_init_formats( $init_array ) {
    $init_array['theme_advanced_blockformats'] = 'p, h2,h3,h4,h5,h6';
    return $init_array;
    }
    add_filter( 'tiny_mce_before_init', 'childtheme_tiny_mce_before_init_formats' );

    Any help is really appreciated, cause I'm going nuts! ;)

    Thanks in advance

    Sascha

    Posted 8 years ago #
  2. i don't think add_editor_style does anything by itself.

    all i do is put an editor-style.css in my child theme's folder and then in it i import my regular styles

    @import url("style.css");

    then the stuff in the post editor will be styled the same. otherwise, i don't know what you mean.

    Posted 8 years ago #
  3. saschapi
    Member

    That's exactly what I'm trying to acomplish. Unfortunately the css file "editor-style.css" in mein child theme is not integrated into the editor iframe. Therefore the styles are not added to the editor view. When I look at it with firebug the css file and the classe do not show up at all. :(

    Posted 8 years ago #
  4. put editor-style.css in your child theme's folder

    and put

    add_editor_style();

    in your child's functions.php

    just confirmed as working in child themes.

    also use google and presto you'll get the exact tutorial you are looking for:

    http://devpress.com/blog/style-the-post-editor-just-like-your-theme/

    justin tadlock has a lot of really great tutorials across his various sites

    Posted 8 years ago #
  5. saschapi
    Member

    Thanks for your answer! I just stripped all the other functions in my functions.php and It works now. Seems I had a conflict there! Once again thanks for confirming that this should work in the first place! :)

    Posted 8 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.