ThemeShaper Forums » Thematic

Adding background image to #content

(3 posts)
  • Started 12 years ago by Devadaru
  • Latest reply from Devadaru
  • This topic is not resolved
  1. Devadaru
    Member

    I'm struggling to add images to a thematic child theme.

    http://www.themetest.vedantadc.org/

    I've added a (rough, test) background image including the header image and everything. This is still very rough, but I want some kind of image behind the text, with rounded corners. What I did: made the image into 3 parts: top, slice, and bottom; applied top to #container, slice to #content (repeat-y), and bottom to .hentry.

    This doesn't work for the http://themetest.vedantadc.org/blog blog page, or for a "page not found".

    I'm sure there's a better way to do this, but I don't know what it is; I am more or less fumbling my way through with firebug and google searches... Hope someone can help.

    Posted 12 years ago #
  2. I think you have the right strategy, but it's not working for the blog because that page has multiple .hentries, and for 404 because there's no .hentry. One workaround would be to put the background on #footer instead of .hentry, positioning it horizontally to get it in the right place or creating a new slice that's the width of the footer, and using top padding to push the footer content down accordingly.

    There might be a better way to do it using one of the Thematic Hooks to add an additional element that you can style at the bottom of #content, but I haven't played with those yet so you would need someone else to advise you.

    Posted 12 years ago #
  3. Devadaru
    Member

    Thanks for the tips and encouragement.

    Posted 12 years ago #

RSS feed for this topic

Reply

You must log in to post.