ThemeShaper Forums » Thematic


Adding Flash to a custom page template

(2 posts)
  • Started 5 years ago by killerpoke
  • Latest reply from killerpoke
  • This topic is not resolved
  1. Hello-hello themeland,

    I have created a template and specified the page – of which the template is applied – to act as the static home page. I am attempting to add Flash to the template. I am using swf_object 2 to generate clean sniffer code.

    swf_object 2 generates the code; I have placed the first part of the code in my header like so:

    <script type="text/javascript" src="swfobject.js"></script>
    <script type="text/javascript">
    swfobject.registerObject("myFlashContent", "5.0.0");

    and I have placed the second and final piece in the template file like so:

    Template Name: home
    <?php get_header(); ?>

    <!--<div id="large_bg_image_home"></div> -->

    <div id="flash">

    <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="984" height="623" id="myFlashContent">
    <param name="movie" value="flashHome.swf" />
    <!--[if !IE]>-->
    <object type="application/x-shockwave-flash" data="flashHome.swf" width="984" height="623">

    <img src="" alt="Get Adobe Flash player" />

    <!--[if !IE]>-->


    <div id="container">

    <div id="content">


    <?php get_footer(); ?>

    All that is visible is an empty white rectangle.

    Any advice greatly appreciated.

    Many thanks in advance,


    Posted 5 years ago #
  2. My mistake. I didn't add the full and absolute url to the <embed src""> attribute. « resolved now.

    Posted 5 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.