ThemeShaper Forums » Thematic

[closed]

Adding ID to existing sidebars

(5 posts)
  • Started 8 years ago by lastraw
  • Latest reply from lastraw
  • This topic is not resolved
  1. I made the mistake of not adding IDs to a sites register sidebar arrays. I would like to go back and add them now, but it breaks. Any suggestions? Thank you!

    Posted 8 years ago #
  2. what's your code look like?

    Posted 8 years ago #
  3. Currently

    //Widgetized sidebar Names
    
        if (function_exists('register_sidebar'))
    
        {
    
        register_sidebar(array(
    
        'before_widget' => '<div class="sidebar_widget">',
            'after_widget' => '</div>',
            'before_title' => '<h3>',
            'after_title' => '</h3>',
    
        'name' => 'Home'
    
        ));

    (repeated for approx 20 sidebars)

    I tried changing it to what I usually use

    //register sidebars
    
    add_action( 'widgets_init', 'my_register_sidebars' );
    
    function my_register_sidebars() {
    
    	/* Register the 'home' sidebar. */
    	register_sidebar(
    		array(
    			'id' => 'home',
    			'name' => __( 'home' ),
    			'description' => __( 'Text for home page.' ),
    			'before_widget' => '<div id="%1$s" class="widget %2$s">',
    			'after_widget' => '</div>',
    			'before_title' => '<h3 class="widget-title">',
    			'after_title' => '</h3>'
    		)
    	);

    But I got the white screen of death.

    Posted 8 years ago #
  4. nothing jumps out at me. but try this to debug the WSOD
    http://www.wprecipes.com/how-to-easily-enabledisable-debug-mode-in-wordpress

    Posted 8 years ago #
  5. thanks, will do.

    Posted 8 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.