ThemeShaper Forums » Thematic

Applying filter in functions.php doesn't remove dropdowns

(6 posts)
  • Started 10 years ago by Craig
  • Latest reply from dannydamnboy
  • This topic is resolved
  1. Hi there,

    I'm creating a child theme on a local copy (wordpress installed via Xampp for PC) of Thematic and it seems that when I apply the code to filter out the dropdowns in functions.php, they remain. I even went a little further and applied the 'add a homepage' filter in the example functions.php and it works fine, but in the the same breath the copy-and-pasted code to remove dropdowns still displays subpages in the usual dropdown manner.

    How strange. Any suggestions as to why this should be so?

    Thanks for your help,

    Craig.

    Posted 10 years ago #
  2. Hey Craig,

    guess that you removed the superfish scripts .. in this case the additional functionality will be removed but you still have the CSS functionality.

    Cheers,

    Chris

    Posted 10 years ago #
  3. Chris,

    Thanks for the response. I feel I don't quite understand. I thought telling functions.php to remove the functionality would remove dropdowns. It doesn't seem to, in fact, nothing seems to have changed at all.

    What should I remove from the CSS to enable subpages to not be shown in the menu?

    Cheers,

    Craig.

    Posted 10 years ago #
  4. Craig,

    the easy way is using

    .sf-menu li ul {
        display:none;
    }

    Cheers,

    Chris

    Posted 10 years ago #
  5. Chris,

    You're a legend.

    Cheers.

    Posted 10 years ago #
  6. He's a legendary gUrU...

    Posted 10 years ago #

RSS feed for this topic

Reply

You must log in to post.