ThemeShaper Forums » Thematic

[closed]

author email public in author's archive

(5 posts)
  • Started 2 years ago by joseluisbolos
  • Latest reply from joseluisbolos
  • This topic is resolved
  1. joseluisbolos
    Member

    After a couple months using Thematic I've just realised that in the authors archive (that's "/author/username/") the email address of the author is public. I've been looking for a way to disable this behaviour but apparently there's none. I've even found this snippet on wp-themes.com while looking for a solution:

    "Thematic currently has three options that can be set from the Theme Options panel under Design: Index Insert Position, Info on Author Page and Text in Footer."

    but alas, there's no Theme Options panel that I know of.

    In the forum I've find several people with the same problem but no solution whatsoever.

    Is there any reasoning for this behaviour/"feature"? Is there any way to disable it?

    Posted 2 years ago #
  2. Kathy will most likely come in and rain on my parade. I checked into the Author info, I could not find a hook for it, it looks like it is hard coded in the template, basically it is either "no author bio" or "author bio with everything".

    The easy way to fix this is to copy your "author.php" from the Thematic folder and drop it into your child theme. Once in your child theme folder, just go in there and wipe out that whole author-email div.

    <div id="author-email">
    <a class="email" title="<?php echo antispambot($authordata->user_email); ?>" href="mailto:<?php echo antispambot($authordata->user_email); ?>"><?php _e('Email ', 'thematic') ?><span class="fn n"><span class="given-name"><?php echo $authordata->first_name; ?></span> <span class="family-name"><?php echo $authordata->last_name; ?></span></span></a>
    <a class="url"  style="display:none;" href="<?php bloginfo( 'url' ) ?>/"><?php bloginfo('name') ?></a>
    </div>

    I usually try not to create more files, but I don't see any way to filter this info or override it. Not to mention this solution is ultra simple, fast and does the job.

    Posted 2 years ago #
  3. You also mentioned "There's no Theme Options panel that I know of."

    The options panel can be found in Appearance > Thematic Options, but you won't find any options other than "on" or "off", no real options. I have a feeling you know that though. ;)

    Posted 2 years ago #
  4. joseluisbolos
    Member

    "The options panel can be found in Appearance > Thematic Options"

    Well , I have a problem then. That option doesn't exist in my installation:
    http://tinypic.com/r/2czacjl/7

    Regarding the email thing, I also don't like to create more files, that's why I was hoping for a simple way to disable it. But it looks like it's the only option here.

    Thanks for your help, really appreciate it.

    Posted 2 years ago #
  5. joseluisbolos
    Member

    All right, so the thing is that I had the line:

    define('DISALLOW_FILE_EDIT', true);

    on wp-config.php as a security measure. Looks like that disable not only the editor, but the theme options too.

    Commented it out, disabled the "Info on Author Page" option, all it's fine and dandy now.

    Marking as solved.

    Posted 2 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.