ThemeShaper Forums » Thematic

Can't get comments to work in posts

(3 posts)
  • Started 4 years ago by AniketPanjwani
  • Latest reply from AniketPanjwani
  • This topic is resolved
  1. AniketPanjwani
    Member

    For whatever reason, comments are no longer working in my posts. When I make a new post, comments and trackbacks are checked. When I publish the post, the comments and trackbacks are not checked. When I try checking them again, they go back to being not checked when I update the page. Comments are already enabled under editing settings -> discussion.

    I've tried disabling all plugins, but it does nothing. This started happening after I was using some plugin to redirect my feeds to feedburner.

    My website is http://www.econhelp.org - posts are located under the articles tab on the navigation bar.

    Is there some php file in thematic I have to change in order to get my comments back to normal?

    Posted 4 years ago #
  2. AniketPanjwani
    Member

    I tried a different theme, k2, and comments are closed there as well.

    Also, in wp_posts table in my database, this was the comment_status field - set to open, I presume.

    comment_status varchar(20) utf8_general_ci No open

    I tried uploading comments.php from thematic once more, but it didn't fix anything.

    Changing permalinks does nothing.

    I'm using wordpress version 2.9.1. This started occurring before I upgraded- upgrade didn't fix anything.

    Where should I even start looking to fix this?

    Posted 4 years ago #
  3. AniketPanjwani
    Member

    I fixed this by removing all wordpress files and databases and starting over again. Hopefully I won't have to do this in the future.

    Posted 4 years ago #

RSS feed for this topic

Reply

You must log in to post.