ThemeShaper Forums » Thematic

[closed]

Category "older posts" link broken

(2 posts)
  • Started 7 years ago by nickbernier
  • Latest reply from nickbernier
  • This topic is resolved
  1. nickbernier
    Member

    A fly on the wall for a while now, managed to resolve previous issues but this one baffles me! Web design is a hobby only so please be kind to me! I've come up with my wife's photography blog child theme template: www.daniellelynnphotography.com/blog/

    All the pages and navigation work well except for the categories pages. If my settings->reading option is set to display 5 posts, in the category page generated for each selected category, I'll get my 5 posts and the "Older posts" link.

    The "older posts" link navigates to what appears to be the proper categoryname/page/2/ but it generates a 404. If I increase my settings->reading option to display 9 posts, then I'll get all 9 displayed and the other ones will again not link properly?

    Archives display and link properly? Just category listings and multi-page links are causing issues?

    Possible causes:

    I added this to my functions.php page to force the full posts instead of excerpts.

    //Change to full posts on category
    function childtheme_content($content) {
    if (is_archive()) {
    $content= 'full';}
    return $content;
    }
    add_filter('thematic_content', 'childtheme_content');

    ----

    I am using the permalink migration plugin? Its given some issues in the past with hijacking subpages, however this only affects categories?

    ----

    Using current Thematic framework (9.6.2) and the latest Wordpress (3.0.1)

    Any help or suggestions would be greatly appreciated!

    Nick

    Posted 7 years ago #
  2. nickbernier
    Member

    Found a solution using this plugin:

    http://wordpress.org/extend/plugins/category-pagination-fix/

    My bad, I wasn't using the proper googling terms!

    Posted 7 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.