ThemeShaper Forums » Thematic

[closed]

child theme only works on dev server

(4 posts)
  • Started 2 years ago by emerisch
  • Latest reply from emerisch
  • This topic is resolved
  1. Hi there,

    I am fairly new to thematic and was very excited to incorporate it into my latest project. Everything worked perfectly fine while I was testing the child theme on my dev/testing server, but once I packaged all the files and tried installing the child theme onto the actual server where it will reside certain things didn't work properly. I have racked my brain and tried a million different things from plugin activation/deactivation to multiple installations on multiple wordpress installs on three different servers. My server seems to be the only one it operates correctly on. Which makes sense since it was my testing environment. But it doesn't shed any light onto why it seems to partially break on the two other servers.

    The home page doesn't appear properly, the blog post excerpts do not appear/the footer does not appear, pretty much the entire bottom half of the home page doesn't show up. There are pages where I've set up different loops for different categories and the excerpts for these show up just fine, right where they are supposed to, but once you click on a single post, none of the single post content appears. The title isn't there, the author meta, the content, nothing. The post div with the correct post ID shows up just fine in the html... but it doesn't contain anything inside. The footer doesn't appear on the single post pages either. Weird right?

    So it seems like some of the hooks might not be rendering properly for some reason? "thematic_singlepost():" maybe?

    But that doesn't explain the excerpts not showing up on the home page either... or the footer not appearing on either of the conflicted page/post pages.

    I have a considerable amount of code inserted into the functions.php file as I thought that's what thematic was all about. But there are a couple files I did the cheater way (uploaded page.php and single.php into the root child theme folder).

    If anyone could shed any light on this at all, or have heard of something similar going on please please please let me know. My client is eager to get their site up soon and I feel horrible that I can't figure this out.

    Thanks so much.

    Posted 2 years ago #
  2. Okay... So I think I've narrowed the problem to something within my functions.php file...

    I renamed that file to functions1.php and things started appearing again... I would hate to ask someone to comb through that file for me because it has 1446 lines of code in it... but I don't really know where to begin... should I just start commenting sections out one by one?

    any advice would be awesome... thank you.

    I still don't get why it would operate fine on my server though and not on another.

    Posted 2 years ago #
  3. yes i usually go section by section. i can probably fix it quickly if you are interested in hiring me for an hour. my email is my screenname at gmail. do make sure you are using the 'slightly' newer version of thematic:

    http://developing.thematic4you.com/thematic-development-release/

    also disable all plugins.

    Posted 2 years ago #
  4. Ah! I figured it out after much hair pulling. Thanks for offering to help helga, much appreciated. But I found out that it was a simple plugin issue. I must have overlooked it because there were so many already installed on their wordpress site.

    Thanks!

    Posted 2 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.