ThemeShaper Forums » Thematic

child themes not working

(17 posts)
  • Started 4 years ago by joecrunk
  • Latest reply from EvilEsq
  • This topic is resolved

Tags:

  1. I am the local newbie.
    I found the most awesome word press theme over at smashing magaizine called "gallery"
    I found out I needed thematic and since then have studied and researched on installing thematic and then child themes.
    So thematic is in my wordpress-content-themes folder with my other themes and works no problem on my dash board.
    Every time I install gallery I get the "broken" missing template message.
    So I down loaded other child themes.
    I have been through three themes now and all are missing some template that makes them broken in my dash board.
    What am I doing wrong? I have been reading and surfing trying to fix this for two days and finally I give up.
    I need some help or a point in the right direction to find my answer.
    Thanks

    Posted 4 years ago #
  2. Yes I did. Here is an update. I just got the "rusty grunge" child theme to work.It is by the same author of the "gallery" theme I want to use.
    I drag dopped "rusty grunge" into the wp-content-themes folder where thematic is <like all the other child themes as well> but the rusty grunge is the only one to work so far.
    I have word press 2.7 and I have thematic 0.9 so I dunno I am stumped.
    I just switched zip programs and :rusty grunge" is working so I am going back to test other themes.
    Thanks for the link though.

    Posted 4 years ago #
  3. update to the update:
    Okay three child themes,"second to none" "sugar cane" and "smoking blue 2" all have the broken and missing template error on my dash board.
    Thematic is always there and working fine.
    And yeah I am installing them one at a time not all at once.
    "Rusty Grunge" worked fine am still testing.
    Really confused why one works and three don't?

    Posted 4 years ago #
  4. Update:
    Gallery 1.1.1 is "broken" "missing template"<still> "Commune" theme "broken" missing template. It is hit or miss with this thing for me right now.
    Any suggestions any one?
    Thanks

    Posted 4 years ago #
  5. I found that if "Template: thematic" is not in the child theme style.css the theme won't show up. I'll review my installation again and see if anything else occurs to me.

    Posted 4 years ago #
  6. Thank you I will try this to on my end.Let me know what happens on your end.

    Posted 4 years ago #
  7. Here's another link that may help your trouble shooting:
    http://wangenweb.com/2008/07/creating-wordpress-child-themes/

    Posted 4 years ago #
  8. Well I just got it working but it doesn't display correctly.
    My site is mechanicallyhuman.com
    I have these now:
    Warning: Invalid argument supplied for foreach() in /home/content/j/o/e/joecrunk/html/wordpress/wp-content/themes/gallery-1.1.1/gallery/index.php on line 3
    and this:
    <div id="post-22" class="
    Fatal error: Call to undefined function thematic_post_class() in /home/content/j/o/e/joecrunk/html/wordpress/wp-content/themes/gallery-1.1.1/gallery/index.php on line 27

    Posted 4 years ago #
  9. Okay well here is the style sheet for gallery.
    I deleted the line with thematic in it at the top and now it loads for some reason but does not display correctly.
    I am a novice on code so I dunno here it is:
    /*
    Theme Name: Gallery, a Thematic child theme
    Theme URI: http://www.chris-wallace.com/2009/05/04/gallery-wordpress-theme/
    Description: The ultimate gallery-style Thematic child theme for WordPress.
    Author: Chris Wallace
    Author URI: http://chris-wallace.com

    .
    This work, like WordPress, is released under GNU General Public License, version 2 (GPL).
    http://www.gnu.org/licenses/old-licenses/gpl-2.0.html
    .
    */

    /* Reset browser defaults */
    @import url('../thematic/library/styles/reset.css');

    /* Apply a basic layout */
    @import url('../thematic/library/layouts/2c-l-fixed.css');

    /* Apply basic image styles */
    @import url('../thematic/library/styles/images.css');

    /* Prepare theme for plugins */
    @import url('../thematic/library/styles/plugins.css');

    input,select,textarea{
    color: #eee;
    background-color: #3F3F3F;
    -moz-border-radius: 3px;
    -webkit-border-radius: 3px;
    border-radius: 3px
    }
    input[type="submit"],
    input[type="button"],

    Posted 4 years ago #
  10. It appears you have an index.php in your child theme directory? Not sure but I don't think that's kosher.

    I suggest this. Delete your current child theme (keep copies of your files). Recreate the directory and copy the files from the thematic-sample-child-theme into your (new) child theme directory. Copy and paste you code snippets into these files.

    Hope that does the trick.

    Posted 4 years ago #
  11. I am pretty green on coding so let me repeat what your saying.
    I have a index.php folder in my child themes directory and that should not be there.
    So I deleted and unzipped the whole gallery child theme package again and right now I am using Aptana to read my files.I switched back to the unedited style shhet where I didn't delete anything
    So I need to take the files out of the index.php file? and move them where?
    Sorry I am reading Html,Xhtml,and css for dummies so I am trying to catch up on the programming end.I have a good grasp but I am still reaching.
    Thanks for all your help.

    Posted 4 years ago #
  12. Scratch my musing in re the index.php file. I just downloaded and installed and activated the Gallery theme on my system with no problem. So I know it works.

    This is likely your problem: When you decompress a theme it creates a top level directory, in this case: "gallery-1.1.1" with a sub directory "gallery" You only want to copy the subdirectory "gallery" and everything below it into your wp-content -> themes directory.

    In the link above, you have a reference to "gallery-1.1.1" which means you included that directory in the hierarchy.

    Delete gallery off your server and reinstall.

    Sorry I didn't catch that before.

    Good luck!

    Posted 4 years ago #
  13. That didn't work either.I tried in my thematic directory, it has a sample child theme.
    I created a folder and named it "sample" in my wp-content-themes directory and put all the files inside from that thematic sample and I get template missing.
    I tried on the gallery theme opening it up and uploading the theme with just the direct path to gallery and it still says I am missing a template.
    Most of the thematic child themes I get the error message template missing.
    I really don't know what I am doing wrong it has to be on my end because other people are using these themes no problem.
    So let me start over with a play by play:
    I go to smashing magazine.com
    I download the gallery theme in a zip folder saved to my documents.
    I unzip the folder using 7 zip which creates an unzipped gallery file.
    If you click on this file it takes you to another folder that says gallery.If you click on that it takes you to all the files for gallery.
    I am hosting on website palace and they offer an FTP.
    So I clicked on the gallery unzipped folder to open it to the second gallery folder and uploaded that to wp-content-themes.
    Thematic its self is my current default template.
    I have no idea what to do.
    Every thing I have read it looks to me I am following the instructions to the T.
    I have the latest version of word press and thematic.
    I am uploading the most direct file path to the folder.
    And still an error.
    I guess I may need to use something other then thematic right now because there is something critical I am missing.
    I am not an advaced enough user to trouble shoot this either which is the real problem.
    Thanks for your help though I will continue to try any suggestions I can get to fix this problem. Its a really sweet theme.

    Posted 4 years ago #
  14. Check that you installed thematic correctly. As with all templates install only from the second level of the unzipped directory down. Your top level directory on your server for thematic should be "thematic" NOT "thematic0.9" If the later is the case, reinstall thematic. Once that is working satisfactorily then do the following again.

    1) Download the newest version of the gallery theme here:
    http://www.chris-wallace.com/2009/05/05/gallery-11-now-available/

    2) Don't put the child theme inside the Thematic directory. Just add it to the 'themes' directory... all directories and files from 'gallery' down... not gallery-1.1.1 down.

    3) Switch to the gallery template in admin panel -> appearance -> themes

    Don't edit anything until you completed the foregoing steps and verify that it's working. You may need to reset your widgets under appearance -> thematic options.

    Posted 4 years ago #
  15. You just might be the smartest person in the world. The entire world.
    The only thing broken was not my theme it was my common sense.
    I made the same mistake with thematic that I was making with the gallery directory.
    I had thematic 0.9 folder instead of the next level in the directory just "thematic".
    I guess some child themes are idiot proof and will work with a wrong directory path and thematic it self was working with an incorrect path so I was convinced I had the only down load of gallery with major bugs even though it worked for the rest of the world.
    Fixed all my directory paths and am sticking my self in the corner for stupid behavior now.
    Thank you so much for your patience and dilegence working with me through this.You are the boom stick.
    grace+peace

    Posted 4 years ago #
  16. You're welcome. Glad to know the patient is finally breathing on its own.

    Cheers!

    Posted 4 years ago #

RSS feed for this topic

Reply

You must log in to post.