ThemeShaper Forums » Thematic

[closed]

Commen in a page?

(7 posts)
  • Started 9 years ago by Huken
  • Latest reply from jana
  • This topic is resolved
  1. Hi, my friends!
    I have a blog! I want to use Thematic theme. But I can't comment in a page. Can you help me?
    Thanks!

    My blog: www.huken.net

    Posted 9 years ago #
  2. Hi,

    if you create / edit a page just add a custom field with the name 'comments' and the value 'comments'.

    Then it works.

    Chris

    Posted 9 years ago #
  3. jana
    Member

    For pages I added this pages.php

    // calling the comments template
    thematic_comments_template();

    in place of this

    if ( get_post_custom_values('comments') )
    thematic_comments_template(); // Add a key/value of "comments" to enable comments on pages!

    But it gave me comments on every page and I want the option to turn them on or off on each page. What did I do wrong?

    Thanks for helping a newbie :)

    Posted 9 years ago #
  4. Hi jana,

    Take a look at this tutorial and it will all start to make sense. Revert the pages.php back to it'd original state then add your custom field key of comments and value of comments

    -Gene

    Posted 9 years ago #
  5. Ack I am a fool and so tired that I forgot to add the link.

    http://forthelose.org/how-to-use-custom-fields-in-wordpress

    Posted 9 years ago #
  6. jana
    Member

    Thanks for the link em hr,
    I'm still not getting it. I understand the reason behind the custom field but I have no idea what to put in the boxes to make the comment box appear at the bottom of the page.

    Can anyone else help. It seems like it should be an easy fix.

    Posted 9 years ago #
  7. jana
    Member

    Resolved ...thanks for the help Flick and em hr

    http://forums.themeshaper.com/topic/comments-not-showing-on-pages?replies=5

    Posted 9 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.