ThemeShaper Forums » Thematic

[closed]

Comments not showing up properly

(7 posts)
  • Started 10 years ago by danielgerrard
  • Latest reply from danielgerrard
  • This topic is not resolved
  1. danielgerrard
    Member

    Hi, I've been using Thematic to create a child theme.

    When viewing a single post, the comments div doesn't show up at all. In Firebug, it comes out like this:

    <div id="comments">
    <div id="respond">
    <h3>Post a Comment</h3>
    <div id="cancel-comment-reply">
    </div>
    <div class="formcontainer">
    </div>
    </div>
    </div>

    It only shows the form to write a new comment, but doesn't show the existing comments.

    Any ideas how to solve this? Thanks!

    Daniel Gerrard

    Posted 10 years ago #
  2. Hi Daniel,

    could you please provide some more details like an URL, WordPress version and so on?!

    In case there are comments, the div id 'comments-list' is missing.

    Chris

    Posted 10 years ago #
  3. danielgerrard
    Member

    Hi Chris,

    It's version 2.8.5.

    I just uploaded it. Here's the link to a single post:
    http://zek.nma.sg/examples/a-paginated-post/

    There are 13 comments for that post.

    I tried disabling all the plugins, the comments still didn't show up in the child theme. I tried changing the theme back to Thematic, and the comments did show up.

    The code's rather messy because I'm still learning... sorry about that.

    Thanks a million.

    Daniel

    Posted 10 years ago #
  4. Do you use your own comments.php in your child theme directory?

    Posted 10 years ago #
  5. danielgerrard
    Member

    Initially I didn't, but even without comments.php in the child theme, the comments didn't show up.

    I created comments.php to try to fix it but it didn't work.

    Posted 10 years ago #
  6. danielgerrard
    Member

    The code in the Child theme's comments.php is a copy of the tutorial, http://themeshaper.com/wordpress-theme-comments-template-tutorial/

    When I comment out the following code:

    <?php /* IF there are comments, show the comments */?>
    <?php /*if ( ! empty($comments_by_type['comment']) ) :*/ ?>
    .
    .
    .
    <?php /*endif;*/ /* if ( $comment_count ) */ ?>

    When I comment it out, there are some comments showing, but it is not the full number (10 out of 13 comments show).

    Posted 10 years ago #
  7. danielgerrard
    Member

    Hey Chris. I've managed to re-do the comments from scratch following instructions on the Wordpress Codex. http://zek.nma.sg/examples/a-paginated-post/#comments I'll try to figure out how I broke the Thematic code when I have more time.

    Posted 10 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.