ThemeShaper Forums » Thematic

[closed]

CSS3 Pie working on home page but not on other pages

(2 posts)
  • Started 2 years ago by sixfootjames
  • Latest reply from sixfootjames
  • This topic is resolved
  1. Hi,

    Thanks to everyone who's helped me with my first ever full WordPress CMS implementation and Thematic as the framework!

    I was wondering though if someone might be able to tell me why it is that CSS3 Pie would work on my home page and not on the other template pages please?

    Here's the link to my site. http://goo.gl/Gc5rB

    In my functions.php file I have the following, I would assueme, it shoule work on all pages especially the header which is shared across all pages.

    function my_render_ie_pie() {
    echo '
    <!--[if lte IE 8]>
    <style type="text/css" media="screen">
    #branding,
    #access .menu,
    #container .home-content .entry-content,
    #container .home-content .entry-content .homeFeatureLeft a,
    .featureBlocks,
    .featureBlocks a,
    .home-content #slider,
    #content-left,
    #content-right,
    .staffDetail ul.staffProfileMenu,
    .staffDetail ul.staffProfileMenu li a,
    #content-left ul li a,
    #content-left ul.children li a
    {
    behavior: url(PIE.php);
    }
    </style>
    <![endif]-->
    ';
    }
    add_action('wp_head', 'my_render_ie_pie', 8);

    Many thanks,
    James

    Posted 2 years ago #
  2. Stuck it in the root and works a charm!

    behavior: url(/PIE.php);

    Thanks!

    Posted 2 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.