ThemeShaper Forums » Thematic

[closed]

Custom Post Type postfooter in 0.9.7.8 r772 archives

(8 posts)
  • Started 2 years ago by umberto
  • Latest reply from umberto
  • This topic is resolved
  1. umberto
    Member

    Wondering if 0.9.7.8 r772 should be generating postfooters on archive pages of CPT. Not happening for me and don't think I've broken anything, but thought I'd check.

    Posted 2 years ago #
  2. no idea. why don't you try the latest version?

    developing.thematic4you.com/thematic-development-release/

    and see if there is any difference?

    Posted 2 years ago #
  3. umberto
    Member

    Thanks Helga, sorry for the late response.

    My bad on the version, I should have said 0.9.8 r772.

    So it is close to the latest dev release.

    I'm having a nosey at this thread - http://forums.themeshaper.com/topic/thematic-098-beta-testers-wanted and will hopefully get my head around the current state of play with CPT.

    Posted 2 years ago #
  4. middlesister
    Member

    I have postfooters on my archive pages of CPT, using thematic from the development release helga linked to above. I think that is r756 though, don't know if anything has changed since then.

    Posted 2 years ago #
  5. umberto
    Member

    thanks middlesister - I've just re-tried that version and not getting postfooters on the CPT archive pages. Are you using a plugin or tweaking the thematic_postfooter to get that result?

    Posted 2 years ago #
  6. middlesister
    Member

    No, it is very bare bones. The CPT has only two fields besides the title. In fact, I didn't even set up links to CPT archive pages (I use the CPT for random quotes/thoughts of the day), but since I use pretty permalinks I can visit them anyway manually.

    Since I didn't make any changes to the archive loop, no other fields than the standard ones show. This means in my case that the only things showing are the title and - the postfooter. And the only thing showing in the postfooter is the published date since my CPT has neither categories nor tags. No tweaks, no plugins.

    Do you use some kind of page template for your CPT?

    Posted 2 years ago #
  7. umberto
    Member

    thanks again middlesister - I've set up a fresh install on my local server to test various configurations using an unmodified thematic child theme.

    At this point, rev 756 seems to show post footer in some archives. Rev 776 (which is not much different to 772) shows less promise. I'm using 776 as it displays custom taxonomies in the post footer. But seems like the revised 776 post footer is still evolving.

    A few other issues need solving like showing displaying CPT in category archives, so I've got a bit of research to do when I can clear some space :\

    Posted 2 years ago #
  8. umberto
    Member

    Just for the record, managed to get 0.9.8 rev776 humming along with CPT and nice postfooters etc. Main problem was I didn't have all the required bits in the CPT 'supports' array.

    Really appreciate all the work going into Thematic and the support and info in this forum. :)

    Posted 2 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.