ThemeShaper Forums » Thematic

[closed]

Custom Shadowbox

(4 posts)
  • Started 2 years ago by amzero427
  • Latest reply from helgatheviking
  • This topic is resolved
  1. amzero427
    Member

    I hope I didn't miss something, but I've looked through the forums and didn't see anything on what I'm looking for...

    I'm trying to get shadowbox to work with a custom shadowbox.js and shadowbox.css . I've tried what is suggested via the plugin page here: http://wordpress.org/extend/plugins/shadowbox-js/faq/

    with no luck. Not sure what I'm doing wrong, but figure it's something very simple that I'm not getting or overlooking. I have the current version from http://www.shadowbox-js.com/ It would be nice to use it with the plugin, but not necessary. I'm pretty sure I know how to call the script from my functions.php, but not positive and a little uncertain how to get it to work with the custom css. Any suggestions would be greatly appreciated :)

    Posted 2 years ago #
  2. can you be more specific? "this plugin doesn't work" is sort of vague. what exactly are you attempting? what do you need to add via functions.php that you don't know how to?

    ok- read the FAQ more closely than i wanted to. i presume you mean:

    function custom_shadowbox_js($url) {
        return get_bloginfo('stylesheet_directory') . '/js/shadowbox.js';
    }
    add_filter('shadowbox-js', 'custom_shadowbox_js');

    that looks tailor-made for just dropping straight into your child's functions.php . verify that your paths are correct.- ie that you have a folder in your childtheme called js and that shadowbox.js is the name of the custom file.

    double check by loading your site and viewing the source. if you see the shadowbox.js coming from your theme then you got that part right.

    `

    Posted 2 years ago #
  3. amzero427
    Member

    Sorry about that, shoulda been more specific. It wasn't working when I put that in my functions.php, but it ended up being due to an error with the custon shadowbox.js I was trying to use. My bad.

    Banged my head against the wall for a while, went back to the original files, and sure enough worked like a charm. Thanks again :)

    Posted 2 years ago #
  4. good. well not that you banged your head on the wall... b/c owww... i've been doing that myself for the past couple of hours on my own dilemma. but good that it is resolved.

    don't forget to mark the post resolved.

    Posted 2 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.