ThemeShaper Forums » Thematic

Default sidebar still appearing along with widgets

(3 posts)
  • Started 10 years ago by mfeldstein
  • Latest reply from mfeldstein
  • This topic is resolved
  1. I've added a few widgets to the "Primary Sidebar" and they are showing on my site just fine (as they do with other themes). However, the default sidebar items that were there before I added the widgets are still there, and there is no obvious way to get rid of them. What am I missing? And more generally, is there some documentation for all the multiple sidebar functionality (e.g., which sidebars appear where) that you can point me to?

    Posted 10 years ago #
  2. Thematic 0.7 will ship with something of a guide. Here's what it'll say about the widget-ready areas:

    Widget-Ready Areas
    Thematic has 13 widget-ready areas, called Asides, that can be used creatively to customize your theme.

    • Primary Aside
      Located immediately after the content area in the markup. Typically used as a sidebar. By default it contains Search, Pages, Categories and Archives widgets. Use the widgets panel under Design to add your own widgets and override the default.
    • Secondary Aside
      Located immediately after the Primary Aside in the markup. Typically used as a sidebar. By default it contains Links, RSS Feeds and Meta widgets.
    • Subsidiary Asides
      Located in the footer. Empty of widgets by default, they will not apear in the theme markup until you add a widget.
    • Index Asides
      Located in the content area of the index, or blog page. Empty of widgets by default, they will not apear in the theme markup until you add a widget. The location of the Index Insert, which appears between posts, is controlled from the theme options page. The default position sets it to appear after the second post.
    • Single Asides
      Located in the content area of single post pages. Empty of widgets by default, they will not apear in the theme markup until you add a widget.
    • Page Asides
      Located in the content area of static pages. Empty of widgets by default, they will not apear in the theme markup until you add a widget.

    Try adding a widget to the secondary aside to get rid of the other widgets.

    Posted 10 years ago #
  3. That worked perfectly, thanks.

    Posted 10 years ago #

RSS feed for this topic

Reply

You must log in to post.