ThemeShaper Forums » ThemeShaper WordPress Themes

Drop down parent categories not displaying all children

(4 posts)
  • Started 5 years ago by radium
  • Latest reply from karlsebastion
  • This topic is resolved
  1. Hello all,
    I am running the Gallery theme using Themeshaper and the theme is not displaying all of the child categories underneath the parent category. I currently have posts in 9 categories (all are child categories) but only the first 6 categories are displaying in the drop down box. My site is http://www.tshirtgalleries.com.

    I've have searched through the theme files but I can't see where the number of categories that display are set. Any help would be greatly appreciated.
    Thanks

    Posted 5 years ago #
  2. Never mind, I fixed it. There was a wp_list_categories limiting the number of categories. I can't believe I missed this.

    Posted 5 years ago #
  3. I am having a similar issue. I am trying to set up may categories to photographs like this:
    By Genre(Parent Category)
    - Wildlife
    - Macro
    - Architecture
    - etc.
    By Location(Parent Category)
    - Asia
    - Africa
    - etc.

    but only sporadic categories are showing up on the menu. Some are parents with only one or two children, and other are children with no parents(orphan categories?) Any help on how to get them to show up correctly would be greatly appreciated. I am a N00B at this.

    My site is here:
    http://griffinstewart.com/main/

    Posted 4 years ago #
  4. Hi guys

    Thanks Radium! I got a result from the fix to extend the Gallery menu's number of categories with the wp_list_categories setting in the functions.php

    However, I still have a limit on the amount of Child categories listed in the drop down menu, currently set at just 3. I actually have 4 child categories for 'Clients' and 'Print Design', but the 4th ones wont show!! My site is www.karlwoodcv.com

    Can anyone advise me here? Im sure this is elementary.

    Posted 4 years ago #

RSS feed for this topic

Reply

You must log in to post.