ThemeShaper Forums » Thematic

Duplicate robots tag

(6 posts)
  • Started 9 years ago by aphorist
  • Latest reply from aphorist
  • This topic is resolved
  1. aphorist
    Member

    After reading this thread, I downloaded the latest SVN this morning. I thought the problem might be with my child theme, so I went back to using Thematic by itself. And I turned off all plugins. Weirdly, I still get two robots tags:


    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>

    <meta name="robots" content="index,follow" />

    <link rel="canonical" href="http://localhost:8888/lajolla"/>

    <link rel="stylesheet" type="text/css" href="http://localhost:8888/lajolla/wp-content/themes/thematic/style.css" />

    <link rel="alternate" type="application/rss+xml" href="http://localhost:8888/lajolla/feed/" title="La Jolla Health Coach Posts RSS feed" />
    <link rel="alternate" type="application/rss+xml" href="http://localhost:8888/lajolla/comments/feed/" title="La Jolla Health Coach Comments RSS feed" />

    <link rel="pingback" href="http://localhost:8888/lajolla/xmlrpc.php" />

    <meta name='robots' content='noindex,nofollow' />

    When I'm using a child theme, using a filter with thematic_show_robots in the functions file removes the first robots tag, but not the second. The problem is that when I activate an SEO plugin, I'm back to having two tags.

    Also, I don't have a description tag.

    Any ideas?

    Posted 9 years ago #
  2. Hey ..

    today seems to be the day for 'weird' problems ;-)

    Did a quick check with the current SVN using Thematic as theme or any other child themes on my local machine and none of these duplicates the meta tag robots .. I get exactly the one tag Thematic should create.

    Could you please post a list of plugins you're using?

    Cheers,

    Chris

    Posted 9 years ago #
  3. This might happen if you have your blog set to private mode (non-public). I forget which settings page in the WP admin it is, but it'll add this:

    <meta name='robots' content='noindex,nofollow' />
    Posted 9 years ago #
  4. Hey Justin,

    thanks a lot for your help!!

    .. settings can be changed under wp-admin / settings / privacy ..

    Cheers,

    Chris

    Posted 9 years ago #
  5. This issue is fixed with SVN Revision 444 .. If the blog is set to non-public, Thematic won't create a meta tag robots.

    Cheers,

    Chris

    Posted 9 years ago #
  6. aphorist
    Member

    Cool! Thanks for a great theme--and a great community.

    Posted 9 years ago #

RSS feed for this topic

Reply

You must log in to post.