ThemeShaper Forums » Thematic

Feature Suggestion: Unique widget identifiers

(5 posts)
  • Started 11 years ago by aphorist
  • Latest reply from aphorist
  • This topic is resolved
  1. aphorist
    Member

    Thematic is currently incompatible with the Tabbed Widgets Plugin, which requires a unique ID for each widget. I contacted the author of the plugin, who suggested that I edit widgets.php, changing every instance of this:

    'before_widget' => "<li class=\"widgetcontainer\">",

    to this:

    'before_widget' => '<li id="%1$s" class="widgetcontainer %2$s">',

    This solved the problem. Unless there's a downside, you might want to include this in a future release of Thematic.

    Cheers,

    Joshua

    Posted 11 years ago #
  2. I'll take a look at that. Thanks, Aphorist.

    Posted 11 years ago #
  3. I've added this to the trunk version. Thanks for pointing that out to me.

    Posted 11 years ago #
  4. This is fixed as of 0.6.

    Posted 11 years ago #
  5. aphorist
    Member

    Wow, that was quick. Thanks!

    Posted 11 years ago #

RSS feed for this topic

Reply

You must log in to post.