ThemeShaper Forums » Thematic

fopen, fread and fclose error on new child theme activation

(1 post)
  • Started 3 years ago by krowchuk
  • This topic is not resolved
  1. Hi,

    I decided that I was far enough along with my child theme that it was time to take it onto my server, so I set up a test site first, to finish up some things. I created a new wordpress install on a sub domain and installed Thematic. I imported my content and everything was fine with 2010 theme, so I grabbed a copy of Thematic from the Theme install under dashboard. Thematic works fine. So, next I uploaded my child theme (which is working fine locally under MAMP) and this is when the trouble started.

    When I select my childtheme and click on preview, I get these errors...

    Warning: fopen(/home1/krowchuk/public_html/test/blog/wp-content/themes/wicked2/style.css) [function.fopen]: failed to open stream: No such file or directory in /home1/krowchuk/public_html/test/blog/wp-includes/functions.php on line 4165
    
    Warning: fread(): supplied argument is not a valid stream resource in /home1/krowchuk/public_html/test/blog/wp-includes/functions.php on line 4168
    
    Warning: fclose(): supplied argument is not a valid stream resource in /home1/krowchuk/public_html/test/blog/wp-includes/functions.php on line 4171

    So, I created a new bare bones child theme, and same thing.

    Anyone have any ideas what went wrong?

    Cheers!
    Chris

    Posted 3 years ago #

RSS feed for this topic

Reply

You must log in to post.