ThemeShaper Forums » Thematic

[closed]

Full-width doesn't work with Blog

(8 posts)
  • Started 3 years ago by chinchila_0
  • Latest reply from eilza49
  • This topic is not resolved
  1. chinchila_0
    Member

    Hi everyone,

    I want to use the Full-Width template provided in the Thematic framework for the Blog page on a website. Other pages work fine, but the Blog page doesn't seem to respond when I change the template from Default to Full-Width. Does anyone have a solution?

    Thanks!

    Posted 3 years ago #
  2. beanfair
    Member

    The full width template is designed for pages. It doesn't contain THE LOOP needed to display the blog posts.
    If you open up both templates in a text editor you can see the difference. You can style the blog template to be full width or you can plug the blog loop into the full width template.

    Posted 3 years ago #
  3. chinchila_0
    Member

    Ah, I see what you mean. Can anyone point me to a function that will remove the sidebar on a blog page? I would rather play with the functions.php file in my child theme than touch the Thematic template files.

    Posted 3 years ago #
  4. beanfair
    Member

    You are right, you don't want to make the changes to the thematic parent theme. Make a copy of the template-page-blog.php and place that copy in your child theme. Now the copy in your child theme will overwrite the parent copy. That is the safe way to make changes to your php files.

    Look for this code at the bottom of the template-page-blog.php that you copied into your child theme.
    '<?php

    // action hook for placing content below #container
    thematic_belowcontainer();

    // calling the standard sidebar
    thematic_sidebar();

    // calling footer.php
    get_footer();

    ?>'

    Just comment out the side bar so the code looks like this

    // calling the standard sidebar
     //   thematic_sidebar();

    That will remove the side bar but you will probably need to make some other CSS changes to achieve the desired aesthetic.

    Posted 3 years ago #
  5. Hi,

    I am looking to accomplish the same (full-width blog), but when I follow beanfair's advice above, the sidebar remains put: http://www.soviroma.no/blog/

    The "primary aside" is called anyhow, and it just doesn't make sense to me.

    Any help greatly appreciated!

    Thanks

    Posted 3 years ago #
  6. are you sure that your page is using the correct template?

    also you don't need a template to remove the sidebar:
    http://forums.themeshaper.com/topic/remove-sidebar

    just substitute in your own conditionals like is_home()

    Posted 3 years ago #
  7. Hi Helga,

    Thanks for your help! You are right, the page does not seem to be using the correct template. It is very strange. I've renamed the template "Blog Wide", which is the template I selected in the backend of the page under "Page Attributes", I've saved it and all. But when I pull up www.soviroma.no/blog, it doesn't seem to be calling that template.

    This is really puzzling to me, would you happen to have any ideas about where I could look for the solution? (I am not using a caching plugin.)

    Thanks a million

    Posted 3 years ago #
  8. Now... It gets even stranger.

    Under "Reading Settings", I've selected a different page for blog posts, "Test". Now, the blog posts are displayed under "Test" (www.soviroma.no/test), and here the selection of "Blog Wide" as a template doesn't make a difference either.

    But with this selection on, if I go to www.soviroma.no/blog, the "Blog Wide" template is called.

    Posted 3 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.