Strict Standards: Redefining already defined constructor for class bbdb in /home/themes/public_html/forums/bb-includes/db-mysql.php on line 12

Strict Standards: Declaration of BB_Walker_Blank::start_lvl() should be compatible with BB_Walker::start_lvl($output) in /home/themes/public_html/forums/bb-includes/classes.php on line 1127

Strict Standards: Declaration of BB_Walker_Blank::end_lvl() should be compatible with BB_Walker::end_lvl($output) in /home/themes/public_html/forums/bb-includes/classes.php on line 1127

Strict Standards: Declaration of BB_Walker_Blank::start_el() should be compatible with BB_Walker::start_el($output) in /home/themes/public_html/forums/bb-includes/classes.php on line 1127

Strict Standards: Declaration of BB_Walker_Blank::end_el() should be compatible with BB_Walker::end_el($output) in /home/themes/public_html/forums/bb-includes/classes.php on line 1127
Gallery Child Theme not Displaying Grid Properly « ThemeShaper Forums

ThemeShaper Forums » ThemeShaper WordPress Themes

[closed]

Gallery Child Theme not Displaying Grid Properly

(3 posts)
  • Started 4 years ago by steveblue
  • Latest reply from nrevell
  • This topic is resolved
  1. steveblue
    Member

    I just did a clean install of Thematic 0.9.7.7 and Chris Wallace's Gallery 1.2.1 on my WordPress 3.0.4 blog. For some reason the posts on the Main Page Template and all Categories are not displaying as a grid, but rather after each post thumbnail there is a line break. The Slide Titles are also not formatted as they should be, instead the text length of the post title creates a margin of the overall thumbnail block from the left side of the page. The hover effect is all broken too. I haven't changed anything about the default code. What could be wrong?

    Website is here: http://installationspace.com/spaces/

    A screenshot can be found here: http://installationspace.com/dump/screenshot.jpg

    Thanks,
    Steve

    Posted 4 years ago #
  2. steveblue
    Member

    Ok,

    It seems all I had to do was add the following code to the Child Theme's functions.php:

    define('THEMATIC_COMPATIBLE_BODY_CLASS', true);
    define('THEMATIC_COMPATIBLE_POST_CLASS', true);
    define('THEMATIC_COMPATIBLE_COMMENT_FORM', true);
    define('THEMATIC_COMPATIBLE_FEEDLINKS', true);

    It would be nice to include a readme or installation instructions in future releases for php novices. Or you could just add these lines in the Gallery functions.php anyways. I'm mainly a designer and could use such information.

    Thanks,
    Steve

    Posted 4 years ago #

  3. Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/themes/public_html/forums/bb-includes/kses.php on line 440

    Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/themes/public_html/forums/bb-includes/kses.php on line 510

    Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/themes/public_html/forums/bb-includes/kses.php on line 512


    Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/themes/public_html/forums/bb-includes/kses.php on line 440

    Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/themes/public_html/forums/bb-includes/kses.php on line 510

    Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/themes/public_html/forums/bb-includes/kses.php on line 512
    nrevell

    Member

    where do you insert this code - I cannot get the category pages to display - however, I got the index grid to display by this found in another site - open your gallery/style.css file in a text editor and change every instance of '.not-singular' to '.blog'
    But no luck getting categories pages to behave . . .

    Posted 4 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.


Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method GA_Filter::spool_analytics() should not be called statically in /home/themes/public_html/forums/bb-includes/wp-functions.php on line 586

Strict Standards: Non-static method GA_Filter::spool_this() should not be called statically in /home/themes/public_html/forums/my-plugins/googleanalytics.php on line 183