ThemeShaper Forums » Thematic

[closed]

Gallery Theme, Thematic & Featured Content Gallery

(27 posts)
  • Started 4 years ago by VonB
  • Latest reply from tabasco
  • This topic is resolved
  1. Hi!

    I installed the gallery theme to my wordpress and thematic framework too, i want to have the featured content gallery but it doesn't appear, i changed the theme to the defaul theme and it worked.

    I also noticed that the dropdown menu in the categories and pages section are "open" like if the mouse was over it, only on safari, firefox works normal. This only happens when i have the Featured Content Gallery plugin activated.

    Thanks! :)

    Posted 4 years ago #
  2. Sorry, here is my site
    http://insidetheapple.org

    Thanks!

    Posted 4 years ago #
  3. I noticed something else, the effect that the thumbnails had when you pass the pointer over its gone. (safari) If i uninstall FCG it works OK, and submenus work OK too.

    Hope someone can help me please, i just want the FCG work ok, and my submenus and thumbnails work properly.

    Thanks!

    Posted 4 years ago #
  4. amygail
    Member

    VonB,
    You've got a few css errors, but I think you're biggest issue is that you need to use "no conflict mode" for your jQuery scripts.

    Try changing this...

    <script type="text/javascript">
            function startGallery() {
                var myGallery = new gallery($('myGallery'), {
                    timed: true
                });
            }
            window.addEvent('domready',startGallery);
        </script>'
    
    to this
    <script type="text/javascript">
    function startGallery() {
    var myGallery = new gallery(jQuery('myGallery'), {
    timed: true
    });
    }
    window.addEvent('domready',startGallery);
    </script>
    `

    Posted 4 years ago #
  5. amygail
    Member

  6. Thanks respone amygail!

    I am new to this, i don't know in which file do i need to change the code, is it on my on my theme (gallery) folder? or on the thematic folder and which is the file?

    Thanks! :)

    Posted 4 years ago #
  7. amygail
    Member

    OK - I THINK that the problem is that the FCG is a mootools script and that's conflicting with the jQuery in the Gallery theme.

    If you just need a slideshow - it may make your life easier to go with :
    http://wordpress.org/extend/plugins/wp-cycle/

    Or look for FCG clone that's created with jQuery

    If your set on using FCG - go to the plugin's forum and search "jQuery conflict" and see if there's a solution.

    Someone else here may chime in with a fix, but that's the best I've got.

    Posted 4 years ago #
  8. OK, thank you so much, i uninstalled FCG, many problems for a slideshow ;) With WP-Cycle, i get a error everytime i want to upload an image, i think that is because file permissions, but which file do i need to change, and which permissions do i give?

    Thanks!

    Posted 4 years ago #
  9. amygail
    Member

    Can you post the error message you're getting?

    Posted 4 years ago #
  10. Hi, sorry, i was out of town, but i have everything working on, the only thing i don't understand is why with some plugins my subemenus of categories are always open like if the mouse was over it, i think is related to the jQuery conflict.

    I'm going to try to find a code for the none conflict to put it in my index.php.

    Thanks you so much!

    Posted 4 years ago #
  11. Hey have a question, now i have the code for the nonconflict, but where do i put it, in which file?

    Thanks

    Posted 4 years ago #
  12. Or at least in which type of file, a .php or .js? Maybe this is a stupid question but im new to this stuff :p

    Posted 4 years ago #
  13. amygail
    Member

    Did you work it out?

    i just went to ...

    http://insidetheapple.org/

    and didn't see any conflict error message

    Posted 4 years ago #
  14. Yep, i will try to look for an answer of the FCG before try again. I'm no the only one with this problem. Or maybe wait for another cool featured post slideshow that doesn't give me those problems. I had tried several, but they aren't what i'm looking for, or they give me this problems. (they don't work, or create a problem with my dropdown menus)

    If you know something that may help me, please let me know. And again, thanks for the help! :D

    Posted 4 years ago #
  15. Hi,

    last try .. this was mentioned in a similar thread: blog post

    Chris

    Posted 4 years ago #
  16. Hi Chris,

    I'm going to give it a try and i let you know my experience.

    Thanks!

    Posted 4 years ago #
  17. Hey Chris! Hey amygail!

    Its working!!!!

    Thank you so much for the help! :D Really happy!

    For the people with this problem... I just added this code

    function addscripts_featured_gallery() {
    if(!function_exists(gallery_styles)) return;
    gallery_styles();
    }
    add_action('wp_head', 'addscripts_featured_gallery', 12);

    and then

    function remove_featured_gallery_scripts() {
    remove_action('wp_head', 'gallery_styles');
    }

    add_action('init','remove_featured_gallery_scripts', 1)

    almost at the end of my functions.php of thematic.

    No problems at all, until now everything its working nice!

    If you want to check ot out:
    http://insidetheapple.org

    This is my frist time asking stuff in a forum, and i'm really happy i find this forum!

    Thanks to both! :D

    Posted 4 years ago #
  18. Almost forgot

    i also added this code

    jQuery.noConflict();

    to many files (i didn't know which was the correct file :p so i tryied many)

    Thanks Again to both!

    Posted 4 years ago #
  19. yahyaayob
    Member

    I am facing the same problem and now I am tyring this out. Wish me luck!

    Posted 4 years ago #
  20. guan
    Member

    Hello,
    I try this solution and i just got the black box with the text, like Max Chirkov explain on this blog...
    In whiches files do you put the jQuery.noConflict(); ? And do you only this line of code ?
    Help-me please !!!!!

    Posted 4 years ago #
  21. I have found that the Dynamic Content Gallery - which looks the same - functions better, less conflicts, validates xhtml and works with Thematic right out of the box. And has more options.

    Posted 4 years ago #
  22. davecrow
    Member

    @defries
    Thanks so much for the Dynamic Content Gallery recomendation! After fighting with Featured Content Gallery for weeks, I gave DCG a try and it worked right out of the box. Plus I really like all the additional options DCG offers. Only wish I would've found it a month ago!

    Posted 3 years ago #
  23. @davecrow Glad I could help :)

    Posted 3 years ago #
  24. TimR
    Member

    ^ I can only get DCG to with if I select jQuery rather than MooTools. Just wondering if you found the same?

    Posted 3 years ago #
  25. Kyle
    Member

    Ya, I found the same to be true. I just got a black box until I switched from MooTools to jQuery. I don't know anything about Javascript, so does it really matter which one is selected?

    UPDATE: I realize now that the jQuery version doesn't include a carousel, which I'd really like to have. Any advice on how to make the MooTools version work?

    Posted 3 years ago #
  26. Hi there! Noted all the trouble with the various gallery plugins, then I tried "WP Nivo Slider" worked perfect for me!

    http://wordpress.org/extend/plugins/wp-nivo-slider/

    Pleasant feeling!

    Posted 3 years ago #
  27. tabasco
    Member

    Hi guys, I realize that this post is pretty old but just figured I'd post just in case it could help someone. The jQuery version does have the carousel but you must select the Heading in the upper right corner of the Slider window to view. Not sure if it's different in the MooTools version as I couldn't get that to work either.

    Posted 2 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.