ThemeShaper Forums » Thematic

Header background colour not showing to edge when window width is less than 760

(18 posts)
  • Started 11 years ago by micktay44
  • Latest reply from micktay44
  • This topic is resolved
  1. Hi

    First off love the theme, it's sweet.

    Whenever the window is minimised to a smaller width than the theme, scrollbars appear at the bottom of the page and when you scroll to the right side, the header background does not completely cover the top of the page. I've been able to modify the default.css file so that the #blog-title and #blog-description background are the same as the #header and this improves the situation slightly although now I need the menu to go right across the page too.

    Ideally I'd like the #header div to be 100% width but doing this changes nothing.

    On a side note I've modified the theme slightly, so that it changes from 2 column to 3 column when it detects subpages and i've also coded in some random header images, but I don't think that this has caused the theme to behave like this.

    Any help would be greatly appreciated.

    Posted 11 years ago #
  2. I've noticed that happens to my blog too. I will investigate ;)

    Posted 11 years ago #
  3. It also happens in thematic 0.8

    Posted 11 years ago #
  4. and in every browser, at least on Windows.

    Posted 11 years ago #
  5. and not only with thematic.

    Posted 11 years ago #
  6. resolved.
    look at this:

    but it means changes to thematic

    Posted 11 years ago #
  7. Could you please try this one:

    #wrapper {min-width:940px;}

    Size depends on your theme. 940px is for standard Thematic.

    Tested with original Thematic in FireFox and IE 7. Even IE 6 works let's say: Nearly OK.

    Let me know, if it works for you.



    Posted 11 years ago #
  8. it works , bu it doesn't resolve the issue completely: a 20px of white space still exist on the right, in footer, header and menu.

    Posted 11 years ago #
  9. sorry, I forgot that my width is 960px. so it is resolved but this change has to be apply to thematic stylesheet.

    Posted 11 years ago #
  10. I think adding a {min-width:940px;} to all the 940px elements in the Thematic layouts would be the best bet. It won't do anything in IE6 but you could always try IE7.js in your Child Theme if it becomes a real issue there.

    I'll add this change to trunk.

    Posted 11 years ago #
  11. OK .. looked into that Springload stuff .. as long as your're designing a theme for one single customer you can do whatever is needed to make the the result look and feel good under any condition.

    In our case this would mean that we need to catch every potential area of the theme that could cause such a problem. So I would need to envelope header, access, footer for sure .. maybe branding .. into this narrow-display-fix thing. Giving up a clean markup for not having 20px.

    .. would a jQuery solution be an option?

    Posted 11 years ago #
  12. ok .. too busy with taking care of my son ;-)

    Posted 11 years ago #
  13. hey guys, adding a {min-width:940px;} to all the 940px elements works fine.

    Posted 11 years ago #
  14. Mea Culpa .. original Thematic is 960px .. and let me check one last thing .. will be right back

    Posted 11 years ago #
  15. .. back again .. did some testing with "Second to None" .. here we have a maximum width of 960px .. and I need only one line:

    body {min-width:960px;}

    Did this test on my local installation using FireBug.

    .. and a last live test with again using FireBug.

    Posted 11 years ago #
  16. Fixed in Revision 282 .. If you're not using one of the provided layouts, you need to integrate the min-width-fix into your style.css

    Posted 11 years ago #
  17. Thanks Chris, a good good good work!

    Posted 11 years ago #
  18. Wow.

    Didn't think I'd get this response, I've not been developing the wordpress section of the site in a while, but I will look into the changes you have suggested and keep you posted sometime in the future.


    Posted 11 years ago #

RSS feed for this topic


You must log in to post.