ThemeShaper Forums » Thematic

[closed]

header image does not print

(6 posts)
  • Started 4 years ago by daveweinberg
  • Latest reply from betyonfire
  • This topic is not resolved
  1. daveweinberg
    Member

    Greetings-

    Created this site for a client using thematic:
    http://www.boothbaycottages.com

    Just received an email from the client saying that the header image does not print on certain printers. Following is an excerpt from the email:

    "3 people in 3 business offices print the web site and the header is not showing up. Tried Firefox and Internet Explorer. At the local biz center, we tried highlighting the whole page and it still did not show up."

    Are there any known issues here?

    Posted 4 years ago #
  2. daveweinberg
    Member

    it does occur to me that the image is a PNG - not sure if some browsers have an issue with this. Would be surprised if Firefox did.

    Posted 4 years ago #
  3. daveweinberg
    Member

    Please help - still cannot get this to print.

    I've done some more research in the wp codex:
    http://codex.wordpress.org/Styling_for_Print

    Tried the method of creating a print.css stylesheet including:

    /* Print Style Sheet */
    @media print {
    body { background:white; color:black; margin:0 }
    #header { }
    #content { }
    #comments { }
    #sidebar { }
    #footer { }
    }

    - added it to my child theme directory, added the following to header.php:

    <link rel="stylesheet" type="text/css" media="print"
    href="<?php bloginfo('stylesheet_directory'); ?>/print.css" />

    not sure what I'm doing wrong - cannot get it to work.

    When I first created this site I followed Ian's instructions for adding a header image to the header:

    #blog-title a {
    background:url(images/bbcHeader5.png) no-repeat top center;
    display:block;
    text-indent:-9000px;
    width: 960px;
    height: 200px;
    position: relative;
    top: 20px;
    right: 65px;
    }

    Posted 4 years ago #
  4. Hi Dave,

    with Ian's solution the header image is a background. Backgrounds will be filtered by Firefox. You need to tell Firefox to print backgrounds (images & colors).

    The current site displays the image using HTML. A current default print will show the image. Using the option 'Print background' will print the image and the surrounding blue color.

    More about this: http://malektips.com/firefox_0026.html

    Chris

    Posted 4 years ago #
  5. daveweinberg
    Member

    Thanks, Chris. A colleague far more versed in code than me corrected the issue by linking directly to the image in header.php and modifying the CSS in the child theme. Allows the header image to print without needing to turn on print BG - http://www.boothbaycottages.com

    Discovered another issue however that seems to be specific to Firefox. When printing Firefox appears to divide/segment its printing across header/content/footer - that is, the first page ONLY prints the header (no content beneath); subsequent pages include all the content; final page is only the footer. Any idea how to correct this? This issue is present on several of the other themeshaper sites: ie http://www.simplerealtytheme.com/ and http://themeshaper.com/thematic-power-blog-theme/

    Thoughts? My client may be willing to pay to have this corrected. I also thing it would be a worthy update to the core construct. Please advise. xbklynyte@gmail.com thanks!

    Posted 4 years ago #
  6. betyonfire
    Member

    I am having the same issue with Firefox -- just the header printing on one page, then the text, then the footer. And the middle page frequently cuts off part of the content. Were you able to solve this problem and if so, can you share your solution?

    Posted 3 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.