ThemeShaper Forums » Thematic

[closed]

How to make Archive display as Single post

(4 posts)
  • Started 3 years ago by IFC Design
  • Latest reply from IFC Design
  • This topic is not resolved
  1. I'm not really sure if this is a WP issue, or Thematic specific, but I'm definitely in murky waters. I'm creating a site (so not live) that uses a custom post type with custom taxonomies. When you click on the taxonomy name in the navigation, I want the first post in that taxonomy to show up using the single.php template. However, the behavior seems to always use archive.php. Since I'm creating a Thematic child theme, I have tried multiple things including:

    • Limiting WP to only show 1 post in the loop
    • Creating an archive.php file in my theme that is a wholesale replacement of the single.php template
    • A few different plugins

    I'm not really sure which tree to bark up try to get the answer. Anybody have thoughts on this?

    Posted 3 years ago #
  2. You'll need to set up a custom taxonomy template if you don't want it to default to archive:
    http://codex.wordpress.org/Template_Hierarchy#Custom_Taxonomies_display

    Posted 3 years ago #
  3. yentb
    Member

    あなたの会社のウェブサイトを通じて、ホームページ製作 お客様のブランド を 宣伝するには、お店?ホームページ制作私たちと一緒に来あなたは、世界中の ホームページ作成何百万人 ホームページ作成ソフト あなたのウェブサイトをしたいのCMSに行って知っている ホームページセミナー それがCMSになれば、全世界だけでなく、CMS あなたのブランドはこのサイト を知っ ている ビジネスブログ (<::>) “Hoang Yen” Welcome to us! don't ban nick!

    Posted 3 years ago #
  4. Hi Devin. I'm aware of the hierarchy, but thanks. I've created a file called, "taxonomy-type.php" that is displayed when I click the taxonomy term in the nav. The problem that I'm having is that Wordpress sees this as an archive. So with Thematic, the body has the "archive" class, and if I set WP to display multiple posts (as I would with the blog), I get multiple posts. This is even when taxonomy-type.php is a carbon copy of single.php.

    Posted 3 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.