ThemeShaper Forums » Thematic

icon not showing in ie?

(4 posts)
  • Started 11 years ago by roar123
  • Latest reply from logicoder
  • This topic is resolved

Tags:

  1. roar123
    Member

    added to functions:

    <?php

    // Favorite Icon
    function childtheme_favicon() { ?>
    <link rel="shortcut icon" href="<?php echo bloginfo('stylesheet_directory') ?>/favicon.ico">

    <?php
    }
    add_action('wp_head', 'childtheme_favicon');
    ?>

    doesn't show my icon in internet explorer---
    shows in firefox
    mybe icon is 2 big its 3,638 bytes? lol i dunno

    Posted 11 years ago #
  2. I resolved this issue.

    Internet explorer seems to accept only FAVICON.ico in the root directory of your website.

    this is the code I've used:

    function fav_scripts() {
    	global $siteurl;
    	if (empty($siteurl)) $siteurl = get_settings('siteurl');
    	$favurl = $siteurl.'/'.'';
    
    	echo '
    
    		<link rel="shortcut icon" href="'.$favurl.'favicon.ico" />
    
    	' ;
    
    	}
    
    	add_action('wp_head', 'fav_scripts');

    plus:

    I have converted my FAV icon from a .png to a .ico file using this useful online tool:

    http://www.html-kit.com/favicon/

    try to take a look at my under developement website:

    altamente decorativo/

    It works both in IE and Firefox

    Hope it helps!

    Posted 11 years ago #
  3. I've noticed that now favicon is shown also in the dashboard page.

    Posted 11 years ago #
  4. Yes, IE search for favicon.ico in root directory.

    see http://en.wikipedia.org/wiki/Favicon

    Posted 11 years ago #

RSS feed for this topic

Reply

You must log in to post.