ThemeShaper Forums » Thematic

[closed]

IE 7 and menu behind content div

(6 posts)
  • Started 9 years ago by jrobben
  • Latest reply from Chris
  • This topic is not resolved

Tags:

  1. my menu is working fine under IE 8 and FF, but dropdown link are behind the container, content, post divisions. I am using the byty child theme by cosmoslabs
    http://www.cozmoslabs.com/2008/10/25/byty-free-child-theme-built-thematic/ . I went so far as to remove all of the images and put z-index:50 on all menu elements - no change. any suggestions?

    Posted 9 years ago #
  2. HI jrobben-

    Oh the dreaded ie z-index bug. Look here for help.

    http://richa.avasthi.name/blogs/tepumpkin/2008/01/11/ie7-lessons-learned/

    And remember I you can't find a fix that works across all browsers, that you can specifically style for ie browsers and versions using the body class In this case: .ie7

    -Gene

    Posted 9 years ago #
  3. those two articles are just about enough to make me go back to using <table>. lol

    Posted 9 years ago #
  4. <CENSORED> ............................. </CENSORED>

    Hi,

    Byty is missing the:

    #header {z-index: 2;}

    in the style.css.

    Chris

    Posted 9 years ago #
  5. Byty finally updated! :)

    Sorry for the grief it caused! Hopefully other users won't get the same problem from now on.

    Posted 9 years ago #
  6. Thanks for your help :)

    Posted 9 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.