ThemeShaper Forums » Thematic

Integrating jScroll into Thematic (need help)

(8 posts)
  • Started 10 years ago by tanmccuin
  • Latest reply from amygail
  • This topic is not resolved
  1. Hi all -

    Decided to give Thematic a go for my next few client sites, and so far i must say i'm enjoying working with it quite a bit, excellent job!

    Currently however i've hit a snag trying to integrate jScroll (jquery scrollbar replacement). I've included the proper files (sans 1.2.6 jquery, as thematic already load 1.2.3) and told it to fire up and work with my #content divs and i'm getting nothing. Nothing breaking either. I've double checked paths and the JS is being found and loading.

    Has anyone had the same problem? is there a work around or an explaination? Much appreciated, thanks for your time

    Posted 10 years ago #
  2. amygail
    Member

    Can you post a link?
    Did you confirm that jscroll is compatible with the version of jQuery that you're currently loading?

    Posted 10 years ago #
  3. Hi Amy -

    Didn't see if it was required, except that he mentions he's using 1.6 in this instance, which almost would suggest it's not version specific. But that could very well be.

    here's the link to the work in progress. Thanks for talking a look.

    http://www.tannermooredesign.com/marspyramid/

    Posted 10 years ago #
  4. amygail
    Member

    OK - NOT and expert - but I think you need to go 'no-conflict' mode.
    The error you're getting is "$ is not a function"

    This is a good read
    http://docs.jquery.com/Using_jQuery_with_Other_Libraries

    I usually just replace all instances of '$' with 'jQuery'

    Posted 10 years ago #
  5. Thanks so much for the help Amy -

    Not quite fixed yet, but it seems like that did something, the standard scroll bar disappeared, but wasn't replaced by anything so there must be some sort of conflict going on. I'm going to mess around and see what happens.

    If anyone else has any thoughts, I'm all ears... I guess it's finally time to properly teach myself jQuery.

    Posted 10 years ago #
  6. amygail
    Member

    Are you using Firebug or the Wed Developer's toolbar/ Firefox - it will help immensely.

    You are getting this error "Exception... "Could not convert JavaScript argument arg 0" nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS"

    Sometimes, if you just google the error you get answers.
    I do see from your header that you're calling two versions of jQuery - It's possible that this is an issue.

    If you dig around (I'm pretty sure even on this forum) you can find out how to 'unregister' the jQuery that's already loading and load your own.

    Personally, I'd find a (scroller) script that uses the current version of jQuery.
    I've been playing with jQuery tools and have found them very easy to implement
    http://flowplayer.org/tools/index.html

    Posted 10 years ago #
  7. Thanks Amy -

    I use the Developer toolbar but havn't spent much time with firebug, but i'll look into it and see what i come up with.

    Thanks again.

    Posted 10 years ago #
  8. amygail
    Member

    Look into jQuery tools too - if I'm finding them easy to implement - anyone should be able to. They work with the version of jQuery that's already being used which really helps.

    Posted 10 years ago #

RSS feed for this topic

Reply

You must log in to post.