ThemeShaper Forums » Thematic

invalid input in parameter URLs not resulting in 404

(4 posts)
  • Started 9 years ago by alxndr
  • Latest reply from Chris
  • This topic is not resolved
  1. alxndr
    Member

    (No URL to show because this site's still in private testing, sorry...)

    I'm set up with almost-pretty URLs (/index.php/etc/) on IIS, and am trying to make sure everything invalid returns a 404.

    Requests like /index.php/20x09/08/ correctly result in a 404, however something like /index.php?m=20x0908results in a yearly archive page which simply doesn't have any content in div#content.

    It was suggested in the WP IRC channel that this is a theme issue, not a WP core issue. Any advice on this?

    Posted 9 years ago #
  2. Hi,

    without using permalinks the 404 using your link examples comes from the server itself (in my case from the Apache server).

    With permalinks the 404 using your link examples comes from WordPress.

    Basically this is not a theme related problem.

    Disable all plugins and see what happens then.

    Chris

    Posted 9 years ago #
  3. alxndr
    Member

    By permalinks do you mean rewritten URLs, like /archives/2009/08/ ?

    Disabled all plugins and there's no change: /index.php/20x09/08/ results in a Wordpress 404 page, and /index.php?m=20x0908 results in a Wordpress archive page with no content.

    Posted 9 years ago #
  4. This is a WP issue :) .. you'll get the same empty archive page with the default Theme.

    Chris

    Posted 9 years ago #

RSS feed for this topic

Reply

You must log in to post.