ThemeShaper Forums » Power Blog

[closed]

Leader Asides Missing in IE7

(7 posts)
  1. curobs
    Member

    Hi- when cross browser testing my site at Adobe BrowserLab I noted under IE7 and Win XP the leader asides are missing. I am currently using them only on the home page. They appear OK in IE8 and Firefox. Is there a fix I can use to address this issue with IE7?

    My site's URL is http://bit.ly/4M15Lq

    Thanks!

    Posted 11 years ago #
  2. Don't do that to me :)

    I can't tell you how many hours I spent to make Power Blog IE whatever compatible .. and you broke it?! :)

    Need to look into it. Seems as if you deleted something essential.

    Chris

    Posted 11 years ago #
  3. curobs
    Member

    Ouch. I empathize! Here are the styling changes I made to the leader attributes. (I am not concerned about IE6 - a lost cause - as I am about IE7). Please let me know if there should be something here that isn't?

    3c-r-fixed-primary-988.css

    #leader-container {
    width:988px;
    margin:0 auto;
    overflow:hidden;
    }

    #leader .aside { //replaced by individual leader attributes in style.css below
    /*
    width:316px;
    float:left;
    margin:0 20px 0 0;
    */
    }

    #leader #third-leader {
    /* margin:0;*/
    }

    style.css

    #leader {
    /* border-bottom:4px solid #ccc;*/
    margin-bottom:-22px;
    padding:22px 0 0px 0;
    background-color: #fff;
    }

    #leader .aside {
    }

    #leader #first-leader {
    width:290px;
    float:left;
    padding:0 10px 0 45px;
    margin: 0;
    }

    #leader #second-leader {
    width:300px;
    float:left;
    padding:0 0 0 20px;
    margin: 0;
    }

    #leader #third-leader {
    width:285px;
    float:left;
    padding:0 15px 0 20px;
    margin: 0;
    }

    Posted 11 years ago #
  4. curobs
    Member

    Here's a couple more under style.css in the content section...

    /* Displays the leader asides only on the home page */
    body.singular #leader,
    body.category #leader,
    body.search-results #leader {
    display:none;
    }

    body.home #leader {
    display:inherit;
    }

    Posted 11 years ago #
  5. curobs
    Member

    Ok, I found the culprit.

    /* Displays the leader asides only on the home page */
    body.singular #leader,
    body.category #leader,
    body.search-results #leader {
    display:none;
    }

    This was keeping the leader from appearing on the home page in IE7.

    I just came across Chris' post <http://forums.themeshaper.com/topic/thematic-feature-site-filter-out-leader-on-all-but-home#post-7245> about an alternative way to do the same thing using functions.php, but cannot find childtheme_pageleader function in either the thematic's functions.php or childtheme powerblog functions.php. Please provide the complete code for childtheme_pageleader function to display the leader asides only on the home or direct me to where I might find this function?

    Thanks!

    Posted 11 years ago #
  6. curobs
    Member

    I noted since that this childtheme_pageleader function appears to be part of the Feature theme, but I already paid for PowerBlog. Any chance of getting this function to use with PB theme if it will work with it, as well?

    Posted 11 years ago #
  7. curobs
    Member

    This is resolved. Somehow I hadn't seen Chris' earlier suggestion to use Widget Logic for this particular issue. Works great now.

    Posted 11 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.