ThemeShaper Forums » Thematic

[closed]

Menu not working on static homepage

(2 posts)
  • Started 8 years ago by carrie
  • Latest reply from carrie
  • This topic is not resolved
  1. carrie
    Member

    I am developing a Thematic child theme and have set my site to have a static homepage using a custom page template, and now the dropdown menus are working on all pages except the home page. The menus on that page DO work just fine when I reset the blog index to just be the default setting, displaying recent posts (ie, when the customized page is not set as the home page, the menus on it work fine).

    This suggests to me that the custom page template is set up OK, and there's something about it being set as the home page which is messing things up.

    Any ideas about how to fix this?

    Here is the custom page template code:

    <?php
    /*
    Template Name: Splash (home page)
    */
    ?>

    <?php get_header(); ?>

    <?php thematic_abovecontainer(); ?>

    <div id="container">

    <?php thematic_abovecontent(); ?>

    <div id="content">

    <?php

    // create the navigation above the content
    thematic_navigation_above();

    // calling the widget area 'index-top'
    get_sidebar('index-top');

    // action hook for placing content above the index loop
    thematic_above_indexloop();

    // action hook creating the index loop
    thematic_indexloop();

    // action hook for placing content below the index loop
    thematic_below_indexloop();

    // calling the widget area 'index-bottom'
    get_sidebar('index-bottom');

    // create the navigation below the content
    thematic_navigation_below();

    ?>

    <div id="fadeshow1"></div>

    <div id="bottom">
    <div id="left"><p>Text goes here</p></div>

    <div id="right">
    <image src="pics/callout-sample1.jpg" />
    </div>

    <!--closing bottom div-->
    </div>
    <!--closing content-->
    </div>

    <?php thematic_belowcontent(); ?>

    <!--closing container-->
    </div>

    <?php // get_sidebar(); ?>

    <?php

    // action hook for placing content below #container
    thematic_belowcontainer();

    // calling the standard sidebar
    thematic_sidebar();

    // calling footer.php
    get_footer();

    ?>

    Thanks so much!

    Posted 8 years ago #
  2. carrie
    Member

    Solved! The fadeshow div (a slideshow) was simply covering up the (working) menu. Ha!
    I assigned it a z-index of 0 and now it's all set.

    Posted 8 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.