ThemeShaper Forums » Thematic

Missing semicolon after php wp_footer?

(6 posts)
  • Started 10 years ago by elshaddai
  • Latest reply from michael
  • This topic is resolved
  1. I'm trying to resolve an issue with the Wordpress.com Stats plug-in and noticed that in Thematic 0.9, there doesn't appear to be a semicolon after 'wp_footer()' in footer.php. I've checked three of my Thematic installations with the same result, so I'm pretty sure it's not something I did. I am not a php guru, however, so I don't know if this makes a difference or not, but I thought I'd pass it along.

    In short, I am seeing '<?php wp_footer() ?>' instead of '<?php wp_footer(); ?>'. Thanks!

    Posted 10 years ago #
  2. There is nothing wrong with that! Php allows it! :)

    Posted 10 years ago #
  3. Okay, thanks for the confirmation on that. I'll look elsewhere for the cause of my plug-in problems...

    Posted 10 years ago #
  4. kellyep
    Member

    The missing semi-colon is causing the 'Google Analytics for WordPress' plugin (version 2.9.3) to incorrectly think that there is no call to wp_footer() in footer.php so it's probably worth adding in to a future version :). I'm using thematic 0.9.5

    Posted 9 years ago #
  5. I'd go ahead and add it to your footer.php file and tell Ian about it. While you CAN call a function without the semicolon, it goes against the thematic coding style. It looks like it was just a typo, and I'm sure Ian wouldn't mind adding it in a future version.

    Posted 9 years ago #
  6. I know almost nothing about php, but it does look like this plugin requires the semicolon in order to be happy. I added it to footer.php and now all is well.

    Posted 9 years ago #

RSS feed for this topic

Reply

You must log in to post.