ThemeShaper Forums » Thematic

My page width is all wrong on a different computer

(6 posts)
  • Started 11 years ago by quercus
  • Latest reply from quercus
  • This topic is resolved
  1. I'm getting discouraged.

    I checked my blog on someone else's computer, and my page extended way off the right-hand side of the screen of that computer. It's a Dell computer, with a screen a bit narrower than mine. It's not ancient or anything.

    This shouldn't be this hard!

    How do I change my Thematic theme so it fits on everyone's computer screens?

    Posted 11 years ago #
  2. OK, so when I switched to the generic parent Thematic theme, it did fit onto the other computer.

    So it must be a problem with the header image that I added in to my child theme. It must be too wide.

    I'll keep on studying this whole process, to see if I can figure out how to fix it. I feel sort of like I'm trying to find my way through a thick forest, in twilight.

    Posted 11 years ago #
  3. Update on this question:

    I tried reducing my banner to 700 px wide, so that it would fit into an 800 X 600 browser window.

    I also started working in Firefox, and downloaded Resizer Browser, so that I could check and see how my page looks.

    There's some kind of layout problem going on when I look at it at that size. I think I need to reduce the padding or margin of the header, so that it doesn't have the big lefthand margin.

    I'll keep working on it, but would appreciate any direction.

    My blog is at bendingtreearts dot com slash blog.

    Posted 11 years ago #
  4. I recommend using Google Analytics and taking note of the browser capabilities of people visiting your site. It's getting really rare these days for visitors to be using 800 x 600 monitors. If less than 10% are using smaller monitors, do you really want to make your design smaller for over 90% of the rest?

    Posted 11 years ago #
  5. Hey, this forum has the perfect setup!

    Your header banner stretches to the full width of my widescreen monitor, but when I resize the browser window to 800 by 600, your forum banner magically shrinks to fit. Without a chunk of it hanging off to the side.

    How do I do that?

    I want my blog to have the same set up (width-wise) that this forum does.

    Posted 11 years ago #
  6. OK, I finally decided on a good compromise. I kept my banner at 940, but I didn't put any images on the right hand side of it.

    So, when someone with an 800 by 600 browser looks, they see the whole title and subtitle and menu bar and post. They just have to horizontal-scroll to see the sidebar stuff.

    I think it works.

    And I finally have my blog in working order, so I can start to actually write.

    After all my questioning and whining, I just wanted to check back in. Thanks!

    Posted 11 years ago #

RSS feed for this topic

Reply

You must log in to post.