ThemeShaper Forums » Thematic

[closed]

Native gallery image page: Thematic tweaks needed

(4 posts)
  • Started 3 years ago by birks
  • Latest reply from birks
  • This topic is resolved
  1. birks
    Member

    Hello, I'm playing around with the native gallery feature in Wordpress, and I've just about got it sorted, apart from two issues with the image page.

    I've got a load of pages, that I've uploaded images to, and then displayed by using the [gallery] tag. When clicking on one of these images I've found the following issues:

    1) Comments are not displayed. I enabled them on the parent pages by adding a custom field as described by esmi on this page: http://wordpress.org/support/topic/337890?replies=9
    The comments form is displayed, and comments are added to the image, but Thematic doesn't display them. The default skin does, so it does work.

    2) I need to add next and previous links to the other images. Matt Rude has a tutorial on how to achieve this on a regular skin by modifying image.php at http://mattrude.com/2009/10/next-gallery-image-link-in-image-posts/
    But, as far as I'm aware Thematic doesn't have an image.php file. What would be the best way to approach this? Would there be a way of adding a little function in funtions.php?

    Any help would be most appreciated, I'm sure I'm not the first to come across these issues.

    Thanks!
    What

    Posted 3 years ago #
  2. birks
    Member

    If anyone is interested, I'm half way there, I found that I needed to copy attachment.php from Thematic, and rename it image.php in my child theme. This sorted out the comments issue fine.

    Still struggling on the next and previous links though. I inserted Matt's code, but I figure that it must need tweaking to get to work with Thematic. I am unsure what it needs to be.

    Lil' help please?

    Posted 3 years ago #
  3. I don’t know if this could possibly be related, but since the [gallery] shortcode outputs code that can’t be validated maybe you find this plugin helpful. http://justintadlock.com/archives/2008/04/13/cleaner-wordpress-gallery-plugin

    Posted 3 years ago #
  4. birks
    Member

    Well, thanks to Webstractions on this page: http://wordpress.org/extend/ideas/topic/improve-gallery-short-code all inline styles and some link to media.php can be removed, which could be the source of it being invalid. I did that and it validates fine.

    Meanwhile, I switched back to the default Wordpress skin and found that the next_image_link() and previous_image_link() in it's image.php worked, so put the code into my skin and voila. Strangely though, Matt's solution then worked when I uploaded new images, but not with the images uploaded before..

    Odd stuff. Anyway, I believe I have a fully working gallery now.

    Bye!

    Posted 3 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.