ThemeShaper Forums » Thematic

Page widget list by page order not title

(7 posts)
  • Started 10 years ago by Devadaru
  • Latest reply from Devadaru
  • This topic is resolved
  1. Devadaru
    Member

    http://themetest.vedantadc.org

    The sidebar widget in thematic lists pages by title. They need to be listed by page order.

    To adjust this using a child theme, one needs to add what precisely to the functions.php file?

    Thanks. D.

    Posted 10 years ago #
  2. This can be adjusted on the widgets page under appearance in the WordPress admin.

    Posted 10 years ago #
  3. Devadaru
    Member

    Thanks, that's what I thought too. But strange, the pages widget, though listed as a widget, has no "add" link beside it; I can't access it to adjust it.

    I notice that thematic provides some default widgets, built in to the sidebar.php file (search, pages, blogroll, etc.); it is that page list which appears currently, and is coded as follows:

    <li id="pages">
    				<h3><?php _e('Pages', 'thematic') ?></h3>
    				<ul>
    <?php wp_list_pages('title_li=&sort_column=post_title' ) ?>
    				</ul>
    			</li>

    It would be a simple matter to edit this file, but then I ruin the whole idea of a child-theme. Might you know why the page-widget in the widgets panel is not activatable? If I wanted, would there be a way to adjust this using the functions.php file? (That's for my learning; though I gather from your reply that there is a simple way to do this).

    Thanks for your help.
    D.

    Posted 10 years ago #
  4. You'll have to add your own pages widget (and other widgets—a minor inconvenience) to the primary aside to override the default. I'll be fixing this in version 1.0.

    Posted 10 years ago #
  5. Devadaru
    Member

    Thanks for your help.

    But strange, the pages widget has no "add" link: see this screenshot.

    It seems that wordpress thinks the pages widget is already active... Any thoughts?

    D.

    Posted 10 years ago #
  6. Try resetting your widgets in the Thematic Options page.

    Posted 10 years ago #
  7. Devadaru
    Member

    Yes, perfect. Thanks very much, that solves the problem. —D.

    Posted 10 years ago #

RSS feed for this topic

Reply

You must log in to post.