ThemeShaper Forums » Thematic

[closed]

'Page Top' Widget not showing on search pages - why?

(5 posts)
  • Started 8 years ago by benfrain.com
  • Latest reply from helgatheviking
  • This topic is not resolved
  1. In the words of Dr. Evil - Somebody throw me a freakin' bone here...

    For reasons that escape me, I can't get the 'Page Top' widget to appear on the search results page or the 'no results found' page. Is there some reason for this I don't know of?

    I have tried turning my functions.php off and styles.css off but the sucker still won't display. I've got a header based widget that displays fine but when I stick the same content in the 'Page Top' widget area it's no go.

    Can anybody explain why this might be?

    Posted 8 years ago #
  2. So... turned out I needed

    // calling the widget area 'page-top'
    	            get_sidebar('page-top');

    In the search loop.

    Posted 8 years ago #
  3. hi ben. take a look at the page and search templates (page.php and search.php respectively)

    in the former you will find:

    // calling the widget area 'page-top'
    get_sidebar('page-top');

    but not in the second, which explains why that widget never will display on the search page.

    Posted 8 years ago #
  4. Hi Helga,

    Yes, as you will see I managed to figure it. I'm learning.... slowly ;)

    Best - Ben

    Posted 8 years ago #
  5. yup. i thought i had beat you to it. ;)

    Posted 8 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.