ThemeShaper Forums » Thematic

[closed]

Post titles missing: flaw in Thematic???

(8 posts)
  • Started 4 years ago by rlebowitz
  • Latest reply from em hr
  • This topic is resolved
  1. rlebowitz
    Member

    Hi,

    I am confounded by the problem of my post titles not showing up on my news page. I have spent the past few days putting up and tearing down my site pages in hopes if finding an answer.

    To be more specific: when you log onto my news page, you see my entries...sans titles!
    http://sandranyanchoka.com/?p=8

    (Right now, my other pages are gone, as I accidentally erased my database as I was installing Wordpress again in an attemtpt to fix this.)

    If anyone can help, I would be most grateful...I can even offer some financial compensation to anyone who help me fix this problem.

    Thank you!
    Robert

    Posted 4 years ago #
  2. have you edited the functions.php at all? maybe added in functions to it?

    Posted 4 years ago #
  3. Since no title appears in the code at all (i.e. not hidden by CSS) I'm guessing the only way that could've happened is if you added some sort of function by accident that removes the page titles.

    Assuming all the original Thematic files are intact as well.

    Posted 4 years ago #
  4. To continue on what Leland and Furfur started... what happens if you delete all the content from your functions.php file? Such that you are no longer applying any functions of your own?

    Also- did you customize any of your own templates? I think especially single.php in this case, as I believe that governs the look of any single blog post. Though I just noticed you are having the title issue on pages as well.

    My suggestion would be to go back to reinstall Thematic and then create the simplest child theme possible... meaning no functions and not even any styling of your own.... strictly importing the stylesheets from Thematic. From there you can add pieces of your functionality back until you id the troublemaker.

    Posted 4 years ago #
  5. Jamie Mitchell
    Member

    have you tried activating thematic, not your child theme, to see if the title comes back, then you know if it is in fact your child theme that has the problem (if you are using one)

    if you really get stuck and want somebody to take a look behind the scenes, just yell out, happy to help.

    j

    Posted 4 years ago #
  6. rlebowitz
    Member

    I wish to thank you all so much.

    All your comments pointed me to examine my functions.php file more carefully and I found the code responsible for the missing titles:

    function remove_postheader_posttitle($title){
    return ('');
    }
    add_filter('thematic_postheader_posttitle','remove_postheader_posttitle');

    It was something I had put in to remove the redundant page titles in thematic, and I had forgotten about it. (I got it from here: http://wordpress.org/support/topic/276528?replies=10)

    Anyway, I have my titles again.

    Thanks again, Furfur, Leland, Helga, and Jamie.
    Robert

    Posted 4 years ago #
  7. Congrats. Very glad you got yourself sorted out. You should mark this thread as resolved. And if you run into any more problems definitely ask here before you delete your database! :) Take care.

    Posted 4 years ago #
  8. Thanks for your help, Furfur, Leland, Helga, and Jamie. This is what community is all about :) I went ahead and marked this resolved.

    Posted 4 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.