ThemeShaper Forums » Thematic

Sandbox Widgets not localized - missing domain

(7 posts)
  • Started 11 years ago by dodeantn
  • Latest reply from Ian Stewart
  • This topic is resolved
  1. dodeantn
    Member

    Hi,

    I've finished localizing "Thematic" in German. It was quite easy, as I've used "poEdit", which automatically scans the source files, and generates a MO-file.

    But I've found a kind of bug in "Thematic":

    In the "functions.php" there should be a line: "load_theme_textdomain('sandbox');"
    If it's not there the widgets, which call the localization functions with "sandbox"-domain won't give any reasonable output.

    Cheers

    Posted 11 years ago #
  2. Oops. Thanks for finding the bug! I'll fix it in the next release (and probably the trunk version tonight).

    Posted 11 years ago #
  3. dodeantn
    Member

    No problem.

    One question regarding the "next release".

    Thematic should ease the management of own themes by providing the possibility to child-theme.

    Is there a way of modifying the theme not just via CSS code, but also PHP code, whilst not loosing the update-capability?

    Cheers

    Posted 11 years ago #
  4. Using functions.php in your child theme.

    Posted 11 years ago #
  5. dodeantn
    Member

    Thanks.

    Should the widgets in "/library/functions/widgets.php" work?

    In my WP-Settings they don't show up under "Widgets", and they don't seem to show up on my blog. In particular I mean the "Search" widget.

    Cheers

    Posted 11 years ago #
  6. I'm not sure I understand. They should work.

    Posted 11 years ago #
  7. Did this get figured out? I can't reproduce this error.

    Posted 11 years ago #

RSS feed for this topic

Reply

You must log in to post.