ThemeShaper Forums » Thematic

[closed]

Second page of search results returns 404 error

(12 posts)
  • Started 7 years ago by fernt
  • Latest reply from fernt
  • This topic is not resolved
  1. fernt
    Member

    Hi,

    If a submit a search on http://www.stockportgrammar.co.uk/ (e.g. http://www.stockportgrammar.co.uk/?s=test&searchsubmit=Search), the second page (and onwards) of search results always returns a 404 error page.

    I've tried disabling the WP-PageNavi plugin and that makes no difference, and I've tried temporarily removing functions.php and that makes no difference either (although it sends me back to the home page rather than to a 404 error page, because the 404 page is created in functions.php).

    I'm completely puzzled as to what's causing it. Has anybody else had the same problem and, if so, how did you fix it?

    Thanks in advance for any help.

    Posted 7 years ago #
  2. are you running any template or have you modified the query in any way? are you running the latest stable thematic?

    http://developing.thematic4you.com/thematic-development-release/

    i'll have to look into it more.

    Posted 7 years ago #
  3. Looks like a permalink / rewrite issue to me. Try going in to the WP-Admin>Settings>Peramalinks and resetting to the default the save and then return and re-set your custom permalink structure and then save again.

    Posted 7 years ago #
  4. fernt
    Member

    Thanks for your suggestions.

    em hr - I've just asked our server guy to make htaccess writable so that I can give this a try.

    helga - I'm running 0.9.7.7, the latest version available from the WordPress themes directory. Is it advisable to be running the latest development release instead?

    I've not modified the query in any way. As I mentioned, if I remove functions.php the problem remains.

    Posted 7 years ago #
  5. fernt
    Member

    em hr - sounds like you're right about it being a permalink issue.

    I just temporarily switched to default permalinks and the search pagination works fine. But as soon as I switch back to month and name the problem returns.

    edit

    I've just noticed something that could possibly give us a clue.

    The URL for the second page of search results when permalinks are set to default is:

    http://www.stockportgrammar.co.uk/?s=test&searchsubmit=Search&paged=2

    This also correctly displays the second page of search results if I copy and paste it into the address bar when permalinks are set to month and name.

    ------

    However, when the permalinks are set to month and name and I try and access the second page of search results via the proper navigation, it tries to send me to...

    http://www.stockportgrammar.co.uk/page/2/?s=test&searchsubmit=Search

    ...which returns the 404.

    Thanks again for your help.

    Posted 7 years ago #
  6. if you switch to the twenty eleven theme do you experience the same issue?

    Posted 7 years ago #
  7. fernt
    Member

    Hmm, that's an excellent idea - I'm just worried that I'll lose my widgets (and I've got dozens of 'em) when I switch themes.

    Let me look into it...

    Thanks again.

    Posted 7 years ago #
  8. Have you tried disabling plugins one by one to see if there is a plugin/rewrite conflict?

    Now is probably a good time to look in to a maintenance-mode or development mirror-site strategy.

    Posted 7 years ago #
  9. you can use the widget-saver plugin to save the location of all your widgets. and then yes, also disable your plugins.

    Posted 7 years ago #
  10. fernt
    Member

    Thanks for the widget-saver tip helga and you're right about the development mirror site, em hr!

    Anyway, after all that, it looks like it must be a problem specific to the server - I've switched to Twenty Eleven, have disabled all the plugins and the problem still exists!

    I'm completely baffled by it... I'll try Stack Exchange!

    Posted 7 years ago #
  11. you can also look at your .htaccess file. good luck!

    Posted 7 years ago #
  12. fernt
    Member

    If I find a fix I'll do my best to keep people posted on here, but if anybody's having the same problem then I've opened a question over on Stack Exchange: http://wordpress.stackexchange.com/questions/41860/link-to-second-page-of-search-results-returns-404-error

    Posted 7 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.