ThemeShaper Forums » Thematic

Separating Trackbacks and comments

(7 posts)
  • Started 4 years ago by maisiefantaisie
  • Latest reply from sunlamp
  • This topic is resolved
  1. I love thematic!....I'm trying to separate my trackbacks from showing up in my comments. I've found a few suggestions online advising how to change commments.php code to place trackbacks in a separate list after comments but they are for earlier versions of wordpress and the coding is a little different. Thanks.

    Posted 4 years ago #
  2. Hi May,

    don't understand what you're trying to do. Comments and tracksbacks are already in two separate lists. Could you please give me some more details?

    Cheers,

    Chris

    Posted 4 years ago #
  3. Not sure what the initial poster had in mind, but I have a trackback vs. comment separation issue. They do appear separately. However, the (feedburner) RSS comment feed is showing trackbacks in addition to the other comments. I would like the RSS comment feed to only show the comments, not the trackbacks. What do I change to make this happen - something in comments.php, feedburner setup, wordpress settings . . . or somewhere else?

    Posted 4 years ago #
  4. Another related issue is that my home page lists x comments, where x is the number of trackbacks + the number of comments. When there is 1 trackback and zero comments, it is confusing as it will say 1 comment, the user clicks on comments, and then sees no comments. Someone reported it to me as a bug last night.

    Desired behavior: Number of comments should list number of comments alone (don't include trackbacks in the total)

    Posted 4 years ago #
  5. Created a ticket for this one.

    Issue 46

    Posted 4 years ago #
  6. Thanks for creating a ticket on this. I've stopped displaying track backs but will turn it back on when the issue is resolved.

    Posted 4 years ago #
  7. sunlamp
    Member

    On a related point, and fixing a personal bugbear, inserting this into style.css removes the list of Trackbacks from the individual post page

    #trackbacks-list {
    display: none;
    }

    Now visitors don't have to scroll past a huge list of trackbacks to get to the 'post your comment' box.

    Posted 4 years ago #

RSS feed for this topic

Reply

You must log in to post.