ThemeShaper Forums » Thematic

[closed]

SF menus aren't working for me

(8 posts)
  • Started 10 years ago by melanieg
  • Latest reply from perryb
  • This topic is not resolved
  1. Here's my devo site (still being designed/developed): http://melaniegladdingdesign.com/emf/

    Using firebug, I can see the additional links, but the dropdown isn't happening/not working/whatever.

    Can anyone see a problem I can't see?

    Thanks in advance for any help!

    Posted 10 years ago #
  2. i'm stumped. in firebug, you can see the javascript working too. i would probably wipe out the style.css and then paste stuff back in bit by bit to see if you can find the offender. it sucks, but it can also be faster and less stressful than trying to debug something.

    but i noticed you also have a gazillion scripts in the header. you should definitely look into using wp_enqueue_script.

    Posted 10 years ago #
  3. I had a similar issue recently: all the right links appearing in the <head> and referenced correctly. It turned out there was a conflict with a plug-in I had installed stopping the menu animations and drop down arrows working correctly and so on.

    Might not be the cause but worth checking.

    Posted 10 years ago #
  4. helgatheviking, thanks for the wp_enqueue_script tip! And I'll check the css to see if that's where the problem is.

    I'm also using BuddyPress on this site - could that be part of the problem?

    Posted 10 years ago #
  5. i'm inclined to agree with perryb, that it could be a conflict with one of your other javascript plugins. try disabling them.

    Posted 10 years ago #
  6. It was the CSS! I removed an overflow:hidden in the #headerBox div. (Can't remember if that was a div id I created or if it came with Thematic.)

    Posted 10 years ago #
  7. nope that's one you made. <facepalm> :) don't forget to mark the thread resolved

    Posted 10 years ago #
  8. Ouch - sounds like the sort of sneaky thing that always catches me out ;)

    Posted 10 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.