ThemeShaper Forums » Thematic

[closed]

Sidebar widgets not changing on static home or blog pages

(4 posts)
  • Started 3 years ago by joshwd
  • Latest reply from helgatheviking
  • This topic is resolved
  1. joshwd
    Member

    I'm using a child theme of Thematic 0.9.7.7. For what it's worth, I've only made a few cosmetic changes to the theme.

    Anyway, I want to change the content of the sidebar - everywhere on the site, really, but in particular the Home page and the Blog page. But no matter where I add or remove widgets, these two pages refuse to change from the default side content (Search, Pages, Categories, Archives). I've tried deleting every widget from every possible sidebar, as well as moving, editing, and adding widgets to Primary Aside, Index Top, Single Top, and Page Top. None of these has any impact on the contents of the sidebar.

    Am I missing something? Or do I need to dive into the php just to edit the sidebar on the home page?

    Thanks!

    Posted 3 years ago #
  2. joshwd
    Member

    Hmm. I made a change to the Menu, and now suddenly it reflected a change. Seems that it only reflects sidebar changes when I make some other edit to the page.

    Posted 3 years ago #
  3. Dominor Novus
    Member

    I've tried this but no luck. I also tried creating a post (this worked before).

    This problem is replete if you search for it.

    I've yet to find an answer.

    I can't begin to describe the delay this has already caused me.

    Posted 3 years ago #
  4. are you having the same problem as the OP w/ widgets not updating?

    first, make sure that you are using the latest stable version of thematic:
    http://developing.thematic4you.com/thematic-development-release/

    second, make sure you disable any form of caching (either plugins or something like cloudflare)

    Posted 3 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.