ThemeShaper Forums » Power Blog

[closed]

Styling individual post titles

(6 posts)
  1. sober
    Member

    some days back, i read a post that detailed about styling individual post titles by mentioning the specific post slug in style sheet. I tried to find that post but i am unsuccessful. Can you point me to the link so that i can bookmark it .

    Thanks in advance

    Posted 4 years ago #
  2. amygail
    Member

    hey sober.

    you'd do something like this

    body.slug-home h1 .entry-title {
    color:blue;

    }
    body.slug-about h1 .entry-title {
    color:blue;

    }

    Posted 4 years ago #
  3. sober
    Member

    thanks but can anybody point me to that detailed and exhaustive tutorial

    Posted 4 years ago #
  4. sober
    Member

    Amygail, thanks for the try but it is not working for me or may be i have entered in the wrong style sheet. Which style sheet do i have to enter this. in powerblog style sheet or thematic style.

    Posted 4 years ago #
  5. amygail
    Member

    I'd guess that you'd enter this in your powerblog style sheet.

    make sure you're changing the "slug" title to the title of your post/page

    body.slug-YOURPAGETITLE h1 .entry-title {
    color:blue;

    }

    Here's a link to the readme for the Sandbox theme which also uses dynamic classes - maybe it will help you understand what this is about

    http://www.plaintxt.org/wp-content/uploads/sandbox_readme.html

    It will make your life easier if you use Firefox + the Web Developers Toolbar (or Firebug)

    Posted 4 years ago #
  6. Amygail, thanks for the try but it is not working for me or may be i have entered in the wrong style sheet. Which style sheet do i have to enter this. in powerblog style sheet or thematic style.

    You always add your CSS modifications to the childtheme’s stylesheet. Why? Because your childtheme’s stylesheet is loaded after the thematic stylesheet is loaded, which means that all CSS will be overruled/overwritten by the stylesheet which is loaded last (which is your childtheme’s stylesheet).

    Maybe you are looking at a cached version of your CSS, make sure you do a proper reload in your browser!

    Beside, amygail’s solution should work if you edited it to the correct slug name.

    Posted 4 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.