ThemeShaper Forums » Thematic

[closed]

Submenu hidden

(6 posts)
  • Started 3 years ago by beanfair
  • Latest reply from him
  • This topic is resolved
  1. beanfair
    Member

    My menu is not showing the submenus on some pages of my site http://wineworldwarehouse.com/test/?page_id=53.
    In Firebug it is showing the sub-menu class as greyed out. It also shows display: none; visibility: hidden; But on other pages the ul sub-menu class is working properly.

    I am scratching my head on this one. Suggestions?

    Posted 3 years ago #
  2. beanfair
    Member

    I have been struggling with the sub-menus staying hidden on all of my internal pages. I have read and re-read the excellent post on menus dymsytified but I am still stymied. I have swapped out the default css code from thematic into my child theme and it still doesn't work. If I switch the entire theme to Thematic my sub-menus do appear so I am thinking it is CSS or code outside of the .sf_menu styles that are causing my problem but I can't find it.

    This is how it should work on all pages http://wineworldwarehouse.com/test/
    This is an example of an internal page that does NOT work http://wineworldwarehouse.com/test/?page_id=55

    Any assistance would be greatly appreciated. It is probably some little thing that my old eyes are missing, but boy are they missing it!

    Posted 3 years ago #
  3. i think it is in your newstyles.css

    .sf-menu li:hover ul,
    .sf-menu li.sfHover ul {
    	left:			0;
    	top:			2.5em; /* match top ul list item height */
    	z-index:		99; /*3000; */
    }

    the z-index is too low... something else is higher. switch it back to the 3000 that was commented out and see what happens.

    Posted 3 years ago #
  4. beanfair
    Member

    Thanks for responding Helga.

    It wasn't working when it was set to 3000. I had changed it to 99 when I copied some sample code trying to fix the issue. Just for giggles I switched it back to 3000 and it still isn't working.

    I am really baffled.

    Posted 3 years ago #
  5. beanfair
    Member

    I found the problem but not the cause of the problem. The stylesheet is not cascading properly on the internal pages. The original style.css was overwriting the new child stylesheet but and giving the following values to

    #access {
        position:relative;
        overflow:hidden;

    It is bad form but until I figure out why it isn't cascading properly, I removed the access rule in the parent css.
    Now it works fine with the following code

    #access {
        border-bottom:none;
        height:32px;
        font-size:13px;
        overflow:visible;
        z-index:100;
    }
    Posted 3 years ago #
  6. him
    Member

    well... though I solved it with:

    header - z-index:9999; overflow:visible;

    But I guess its something to do with Wordpress, because I have another child-theme working fine in 3.0.1 but in 3.0.3 I faced the same problem.

    Posted 3 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.