ThemeShaper Forums » Thematic

[closed]

Subnav disappearing behind body

(4 posts)
  • Started 9 years ago by TannerM
  • Latest reply from flick
  • This topic is resolved
  1. I'm having the most interesting effect on a site i'm currently developing. I should have been paying attention, but somewhere along the line, the sub nav's started disappearing.
    you can have a look at it here.

    http://tannermooredesign.com/ocmccuins/plumbingandheating/
    if you roll over plumbing and heating you'll notice a little bit of offset blue shows up, but the content of the drop down is hidden somehow, below the cut of either the header or the page content.

    If anyone can have a look at my css i'd be greatly appreciative, i've gone back through and replaced everything - and apart from completely reseting the CSS this problem seems to persist. I feel like it might have something to do with the top paddings i removed from the container / #main / etc - in order to achieve the effect of the tab connecting with body content.

    Thanks in advance,

    Tanner M

    Posted 9 years ago #
  2. Hey Tanner. I spent about 20 minutes with it, but had no luck. If I had more time I'd first fix all the validation errors and count your divs: http://validator.w3.org/check?verbose=1&uri=http%3A%2F%2Ftannermooredesign.com%2Focmccuins%2Fplumbingandheating%2F. Make sure your html is correct.

    Once that's in, go with the original stylesheet for thematic (where it functions correctly) and then start adding your styles in section by section- testing each time you paste a new block in. That should help you narrow down where the bug is.

    The site looks really nice. Good luck.

    Posted 9 years ago #
  3. fixed. very simple little mistake where i for some reason took out #access {overflow:visible} incredible the ammount of time you can spend looking for one simple mistake.

    As for the validation issues, i might have to post another request, i think the problem is in my functions file - my php is pretty rough.

    Thanks for having a look Devin.

    Posted 9 years ago #
  4. Never thought about using 'centre top' to position the bg before - thanks :)

    Posted 9 years ago #

RSS feed for this topic

Topic Closed

This topic has been closed to new replies.